From 6e75c0bafb6b4310d513a0cce910a981cbcea2f8 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Fri, 22 Sep 2023 08:27:13 +0200
Subject: use oracle client library version 21.11 on x86_64, 19.19 on aarch64

use official Oracle Instant Client RPM
---
 failed.txt |  4 ++--
 php.spec   | 39 ++++++++++++++++++++++++++-------------
 2 files changed, 28 insertions(+), 15 deletions(-)

diff --git a/failed.txt b/failed.txt
index 53467e2..c20f2a3 100644
--- a/failed.txt
+++ b/failed.txt
@@ -5,12 +5,12 @@ $ grep -ar 'Tests failed' /var/lib/mock/*/build.log
 /var/lib/mock/scl74el7x/build.log:Tests failed     :    0
 /var/lib/mock/scl74el8x/build.log:Tests failed     :    0
 /var/lib/mock/scl74el9x/build.log:Tests failed     :    0
-/var/lib/mock/scl74fc36x/build.log:Tests failed    :    0
 /var/lib/mock/scl74fc37x/build.log:Tests failed    :    0
 /var/lib/mock/scl74fc38x/build.log:Tests failed    :    1
+/var/lib/mock/scl74fc39x/build.log:Tests failed    :    1
 
 
-fc38x:
+fc38x, fc39x:
 	3	openssl_private_decrypt() tests [ext/openssl/tests/openssl_private_decrypt_basic.phpt]
 
 
diff --git a/php.spec b/php.spec
index 7d75a9b..5d549bf 100644
--- a/php.spec
+++ b/php.spec
@@ -49,8 +49,15 @@
 
 %global mysql_sock %(mysql_config --socket  2>/dev/null || echo /var/lib/mysql/mysql.sock)
 
-%global oraclever 21.10
+%ifarch aarch64
+%global oraclever 19.19
+%global oraclelib 19.1
+%global oracledir 19.19
+%else
+%global oraclever 21.11
 %global oraclelib 21.1
+%global oracledir 21
+%endif
 
 # Build for LiteSpeed Web Server (LSAPI)
 %global with_lsws     1
@@ -110,7 +117,7 @@
 Summary: PHP scripting language for creating dynamic web sites
 Name:    %{?scl_prefix}php
 Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 8%{?dist}
+Release: 9%{?dist}
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
 # TSRM is licensed under BSD
@@ -361,6 +368,7 @@ Summary: Common files for PHP
 # regex, libmagic are licensed under BSD
 License: PHP and BSD
 
+Requires:  tzdata
 %if %{with_libpcre}
 %global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
 Requires:  pcre2%{?_isa} >= %{pcre2_buildver}
@@ -626,7 +634,14 @@ Summary:        A module for PHP applications that use OCI8 databases
 Group:          Development/Languages
 # All files licensed under PHP version 3.01
 License:        PHP
+%ifarch aarch64
+BuildRequires:  oracle-instantclient%{oraclever}-devel
+# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
+Requires:       libclntsh.so.%{oraclelib}
+AutoReq:        0
+%else
 BuildRequires:  oracle-instantclient-devel >= %{oraclever}
+%endif
 Requires:       %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
 Provides:       %{?scl_prefix}php_database
 Provides:       %{?scl_prefix}php-pdo_oci
@@ -635,8 +650,6 @@ Obsoletes:      %{?scl_prefix}php-pecl-oci8         <= %{oci8ver}
 Conflicts:      %{?scl_prefix}php-pecl-oci8         >  %{oci8ver}
 Provides:       %{?scl_prefix}php-pecl(oci8)         = %{oci8ver}
 Provides:       %{?scl_prefix}php-pecl(oci8)%{?_isa} = %{oci8ver}
-# Should requires libclntsh.so.18.3, but it's not provided by Oracle RPM.
-AutoReq:        0
 
 %description oci8
 The %{?scl_prefix}php-oci8 packages provides the OCI8 extension version %{oci8ver}
@@ -646,13 +659,9 @@ The extension is linked with Oracle client libraries %{oraclever}
 (Oracle Instant Client).  For details, see Oracle's note
 "Oracle Client / Server Interoperability Support" (ID 207303.1).
 
-You must install libclntsh.so.%{oraclelib} to use this package, provided
-in the database installation, or in the free Oracle Instant Client
-available from Oracle.
-
-Notice:
-- %{?scl_prefix}php-oci8 provides oci8 and pdo_oci extensions from php sources.
-- %{?scl_prefix}php-pecl-oci8 only provides oci8 extension.
+You must install libclntsh.so.%{oraclelib} to use this package,
+provided by Oracle Instant Client RPM available from Oracle on:
+https://www.oracle.com/database/technologies/instant-client/downloads.html
 
 Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
 %endif
@@ -1237,8 +1246,8 @@ build --libdir=%{_libdir}/php \
       --with-mysqli=shared,mysqlnd \
       --with-mysql-sock=%{mysql_sock} \
 %if %{with_oci8}
-      --with-oci8=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
-      --with-pdo-oci=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
+         --with-oci8=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
+      --with-pdo-oci=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
 %endif
 %if %{with_interbase}
       --with-pdo-firebird=shared \
@@ -1858,6 +1867,10 @@ EOF
 
 
 %changelog
+* Thu Sep 21 2023 Remi Collet <remi@remirepo.net> - 7.4.33-9
+- use oracle client library version 21.11 on x86_64, 19.19 on aarch64
+- use official Oracle Instant Client RPM
+
 * Tue Aug  1 2023 Remi Collet <remi@remirepo.net> - 7.4.33-8
 - Fix Security issue with external entity loading in XML without enabling it
   GHSA-3qrf-m4j2-pcrr CVE-2023-3823
-- 
cgit