From 29ae9d95bc936a7c3d338d05e3b893f11fa4d47c Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Thu, 28 Jan 2021 17:28:15 +0100
Subject: add upstream patch for https://bugs.php.net/80682   fix opcache
 doesn't honour pcre.jit option

---
 php-bug80682.patch | 30 ++++++++++++++++++++++++++++++
 php.spec           |  8 +++++++-
 2 files changed, 37 insertions(+), 1 deletion(-)
 create mode 100644 php-bug80682.patch

diff --git a/php-bug80682.patch b/php-bug80682.patch
new file mode 100644
index 0000000..38f908b
--- /dev/null
+++ b/php-bug80682.patch
@@ -0,0 +1,30 @@
+From 067f7e4150d8f9bddf6b198c9c7826565ee549b0 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Thu, 28 Jan 2021 16:24:39 +0100
+Subject: [PATCH] Fix #80682 opcache doesn't honour pcre.jit option
+
+---
+ ext/opcache/zend_accelerator_blacklist.c | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/ext/opcache/zend_accelerator_blacklist.c b/ext/opcache/zend_accelerator_blacklist.c
+index 889fcabd7988..5c6bd76821a5 100644
+--- a/ext/opcache/zend_accelerator_blacklist.c
++++ b/ext/opcache/zend_accelerator_blacklist.c
+@@ -185,10 +185,12 @@ static void zend_accel_blacklist_update_regexp(zend_blacklist *blacklist)
+ 				return;
+ 			}
+ #ifdef HAVE_PCRE_JIT_SUPPORT
+-			if (0 > pcre2_jit_compile(it->re, PCRE2_JIT_COMPLETE)) {
+-				/* Don't return here, even JIT could fail to compile, the pattern is still usable. */
+-				pcre2_get_error_message(errnumber, pcre_error, sizeof(pcre_error));
+-				zend_accel_error(ACCEL_LOG_WARNING, "Blacklist JIT compilation failed, %s\n", pcre_error);
++			if (PCRE_G(jit)) {
++				if (0 > pcre2_jit_compile(it->re, PCRE2_JIT_COMPLETE)) {
++					/* Don't return here, even JIT could fail to compile, the pattern is still usable. */
++					pcre2_get_error_message(errnumber, pcre_error, sizeof(pcre_error));
++					zend_accel_error(ACCEL_LOG_WARNING, "Blacklist JIT compilation failed, %s\n", pcre_error);
++				}
+ 			}
+ #endif
+ 			/* prepare for the next iteration */
diff --git a/php.spec b/php.spec
index c7445e1..564b40a 100644
--- a/php.spec
+++ b/php.spec
@@ -106,7 +106,7 @@
 Summary: PHP scripting language for creating dynamic web sites
 Name:    %{?scl_prefix}php
 Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}
+Release: 2%{?dist}
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
 # TSRM is licensed under BSD
@@ -163,6 +163,7 @@ Patch47: php-7.4.8-phpinfo.patch
 Patch91: php-7.2.0-oci8conf.patch
 
 # Upstream fixes (100+)
+Patch100: php-bug80682.patch
 
 # Security fixes (200+)
 
@@ -936,6 +937,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
 %patch91 -p1 -b .remi-oci8
 
 # upstream patches
+%patch100 -p1 -b .bug80682
 
 # security patches
 
@@ -1813,6 +1815,10 @@ fi
 
 
 %changelog
+* Thu Jan 28 2021 Remi Collet <remi@remirepo.net> - 7.4.15~RC2-2
+- add upstream patch for https://bugs.php.net/80682
+  fix opcache doesn't honour pcre.jit option
+
 * Tue Jan 19 2021 Remi Collet <remi@remirepo.net> - 7.4.15~RC2-1
 - update to 7.4.15RC2
 
-- 
cgit