summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php.spec b/php.spec
index 0f9e7e9..6ee988b 100644
--- a/php.spec
+++ b/php.spec
@@ -96,8 +96,8 @@
#global gh_date 20190612
%global gh_owner php
%global gh_project php-src
-%global upver 7.4.24
-#global rcver RC1
+%global upver 7.4.25
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -820,9 +820,9 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 65
-BuildRequires: pkgconfig(icu-io) >= 65
-BuildRequires: pkgconfig(icu-uc) >= 65
+BuildRequires: pkgconfig(icu-i18n) >= 69
+BuildRequires: pkgconfig(icu-io) >= 69
+BuildRequires: pkgconfig(icu-uc) >= 69
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -1478,7 +1478,7 @@ TESTCMD="$RPM_BUILD_ROOT%{_bindir}/php --no-php-ini"
# Ensure all provided extensions are really there
for mod in core date filter hash libxml openssl pcntl pcre readline reflection session spl standard zlib
do
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
done
TESTCMD="$TESTCMD --define extension_dir=$RPM_BUILD_ROOT%{_libdir}/php/modules"
@@ -1539,7 +1539,7 @@ do
ini=20-${mod}.ini;;
esac
- $TESTCMD --modules | grep -qi $mod
+ $TESTCMD --modules | grep -i "$mod\$"
# some extensions have their own config file
if [ -f ${ini} ]; then
@@ -1815,6 +1815,10 @@ fi
%changelog
+* Wed Oct 6 2021 Remi Collet <remi@remirepo.net> - 7.4.25~RC1-1
+- update to 7.4.24RC1
+- use libicu version 69
+
* Tue Sep 21 2021 Remi Collet <remi@remirepo.net> - 7.4.24-1
- Update to 7.4.24 - http://www.php.net/releases/7_4_24.php