summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec58
1 files changed, 30 insertions, 28 deletions
diff --git a/php.spec b/php.spec
index 22f7d4b..883969b 100644
--- a/php.spec
+++ b/php.spec
@@ -49,7 +49,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.8
+%global oraclever 21.10
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -110,7 +110,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 5%{?dist}
+Release: 6%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -839,9 +839,9 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 71
-BuildRequires: pkgconfig(icu-io) >= 71
-BuildRequires: pkgconfig(icu-uc) >= 71
+BuildRequires: pkgconfig(icu-i18n) >= 72
+BuildRequires: pkgconfig(icu-io) >= 72
+BuildRequires: pkgconfig(icu-uc) >= 72
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -934,42 +934,38 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
%endif
-%patch1 -p1 -b .mpmcheck
-%patch5 -p1 -b .includedir
-%patch6 -p1 -b .embed
-%patch8 -p1 -b .libdb
-%if 0%{?rhel}
-%patch9 -p1 -b .curltls
+%patch -P1 -p1 -b .mpmcheck
+%patch -P5 -p1 -b .includedir
+%patch -P6 -p1 -b .embed
+%patch -P8 -p1 -b .libdb
+%if 0%{?rhel} == 7
+%patch -P9 -p1 -b .curltls
%endif
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 6
-%patch42 -p1 -b .systzdata
-%endif
-%patch43 -p1 -b .headers
+%patch -P42 -p1 -b .systzdata
+%patch -P43 -p1 -b .headers
sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
-%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
-%patch45 -p1 -b .ldap_r
-%endif
-%patch46 -p1 -b .argon2
-%patch47 -p1 -b .phpinfo
-%patch48 -p1 -b .snmp
+%patch -P45 -p1 -b .ldap_r
+%patch -P46 -p1 -b .argon2
+%patch -P47 -p1 -b .phpinfo
+%patch -P48 -p1 -b .snmp
%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9
-%patch50 -p1 -b .openssl3
+%patch -P50 -p1 -b .openssl3
rm ext/openssl/tests/p12_with_extra_certs.p12
%endif
-%patch91 -p1 -b .remi-oci8
+%patch -P91 -p1 -b .remi-oci8
# upstream patches
# security patches
-%patch200 -p1 -b .bug81740
-%patch201 -p1 -b .bug81744
-%patch202 -p1 -b .bug81746
-%patch203 -p1 -b .cve0662
+%patch -P200 -p1 -b .bug81740
+%patch -P201 -p1 -b .bug81744
+%patch -P202 -p1 -b .bug81746
+%patch -P203 -p1 -b .cve0662
# Fixes for tests
-%patch300 -p1 -b .datetests
+%patch -P300 -p1 -b .datetests
# WIP patch
@@ -1856,6 +1852,12 @@ EOF
%changelog
+* Fri Apr 14 2023 Remi Collet <remi@remirepo.net> - 7.4.33-6
+- use ICU 72.1
+- use oracle client library version 21.10
+- fix possible buffer overflow in date
+- define %%php74___phpize and %%php74___phpconfig
+
* Tue Feb 21 2023 Remi Collet <remi@remirepo.net> - 7.4.33-5
- F38: enable imap extension