summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--10-opcache.ini2
-rw-r--r--failed.txt6
-rw-r--r--php-7.4.0-embed.patch (renamed from php-5.6.3-embed.patch)6
-rw-r--r--php-7.4.0-httpd.patch (renamed from php-7.1.7-httpd.patch)5
-rw-r--r--php.spec25
5 files changed, 20 insertions, 24 deletions
diff --git a/10-opcache.ini b/10-opcache.ini
index 2abdeb2..a187524 100644
--- a/10-opcache.ini
+++ b/10-opcache.ini
@@ -47,7 +47,7 @@ opcache.max_accelerated_files=4000
; A bitmask, where each bit enables or disables the appropriate OPcache
; passes
-;opcache.optimization_level=0x7FFFBFFF
+;opcache.optimization_level=0x7FFEBFFF
; This hack should only be enabled to work around "Cannot redeclare class"
; errors.
diff --git a/failed.txt b/failed.txt
index 58d604a..7ec883a 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,15 +1,13 @@
-===== 7.4.0alpha1 (2019-06-13)
+===== 7.4.0alpha3 (2019-07-11)
$ grep -ar 'Tests failed' /var/lib/mock/scl74*/build.log
/var/lib/mock/scl74el7x/build.log:Tests failed : 0
/var/lib/mock/scl74el8x/build.log:Tests failed : 15
/var/lib/mock/scl74fc29x/build.log:Tests failed : 0
-/var/lib/mock/scl74fc30x/build.log:Tests failed : 1
+/var/lib/mock/scl74fc30x/build.log:Tests failed : 0
-fc30x
- 5 SPL: DirectoryIterator and clone [ext/spl/tests/dit_004.phpt]
(1) proc_open give erratic test results :(
diff --git a/php-5.6.3-embed.patch b/php-7.4.0-embed.patch
index d9c04f6..1bfd1da 100644
--- a/php-5.6.3-embed.patch
+++ b/php-7.4.0-embed.patch
@@ -1,6 +1,6 @@
--- php-5.6.3/sapi/embed/config.m4.embed
+++ php-5.6.3/sapi/embed/config.m4
-@@ -12,7 +12,8 @@ if test "$PHP_EMBED" != "no"; then
+@@ -11,7 +11,8 @@ if test "$PHP_EMBED" != "no"; then
case "$PHP_EMBED" in
yes|shared)
PHP_EMBED_TYPE=shared
@@ -19,6 +19,6 @@ diff -up php-5.5.30/scripts/php-config.in.old php-5.5.30/scripts/php-config.in
configure_options="@CONFIGURE_OPTIONS@"
-php_sapis="@PHP_INSTALLED_SAPIS@"
+php_sapis="apache2handler embed fpm @PHP_INSTALLED_SAPIS@"
+ ini_dir="@EXPANDED_PHP_CONFIG_FILE_SCAN_DIR@"
+ ini_path="@EXPANDED_PHP_CONFIG_FILE_PATH@"
- # Set php_cli_binary and php_cgi_binary if available
- for sapi in $php_sapis; do
diff --git a/php-7.1.7-httpd.patch b/php-7.4.0-httpd.patch
index acb3d2c..34f7c8a 100644
--- a/php-7.1.7-httpd.patch
+++ b/php-7.4.0-httpd.patch
@@ -5,10 +5,9 @@ mod_php is build twice
- as ZTS using --enable-maintainer-zts
diff --git a/sapi/apache2handler/config.m4 b/sapi/apache2handler/config.m4
-index 2e64b21..ec4799f 100644
--- a/sapi/apache2handler/config.m4
+++ b/sapi/apache2handler/config.m4
-@@ -116,17 +116,6 @@ if test "$PHP_APXS2" != "no"; then
+@@ -105,17 +105,6 @@ if test "$PHP_APXS2" != "no"; then
;;
esac
@@ -18,7 +17,7 @@ index 2e64b21..ec4799f 100644
- PHP_BUILD_THREAD_SAFE
- fi
- else
-- APACHE_THREADED_MPM=`$APXS_HTTPD -V | grep 'threaded:.*yes'`
+- APACHE_THREADED_MPM=`$APXS_HTTPD -V 2>/dev/null | grep 'threaded:.*yes'`
- if test -n "$APACHE_THREADED_MPM"; then
- PHP_BUILD_THREAD_SAFE
- fi
diff --git a/php.spec b/php.spec
index 8e546dc..1cc834c 100644
--- a/php.spec
+++ b/php.spec
@@ -103,13 +103,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 7.4.0
-%global rcver alpha2
-%global lower alpha2
+%global rcver alpha3
+%global lower alpha3
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 11%{?dist}
+Release: 12%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -143,9 +143,9 @@ Source52: 20-oci8.ini
Source53: 20-ffi.ini
# Build fixes
-Patch1: php-7.1.7-httpd.patch
+Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
-Patch6: php-5.6.3-embed.patch
+Patch6: php-7.4.0-embed.patch
Patch7: php-7.4.0-recode.patch
Patch8: php-7.2.0-libdb.patch
Patch9: php-7.0.7-curl.patch
@@ -206,7 +206,6 @@ BuildRequires: libtool-ltdl-devel
%if %{with_dtrace}
BuildRequires: %{?dtsprefix}systemtap-sdt-devel
%endif
-BuildRequires: pkgconfig(libargon2)
%if 0%{?gh_date}
BuildRequires: bison
BuildRequires: re2c
@@ -384,7 +383,6 @@ Requires: gcc-c++
Requires: libtool
# see "php-config --libs"
Requires: krb5-devel%{?_isa}
-Requires: libargon2-devel%{?_isa}
Requires: libedit-devel%{?_isa}
Requires: libxml2-devel%{?_isa}
Requires: openssl-devel%{?_isa} >= 1.0.1
@@ -878,8 +876,8 @@ Summary: Wrapper for the Sodium cryptographic library
# All files licensed under PHP version 3.0.1
License: PHP
Group: System Environment/Libraries
-# Ensure libsodium-last is used (upstream 1.0.9)
-BuildRequires: pkgconfig(libsodium) >= 1.0.13
+# Minimal is 1.0.8, 1.0.14 is needed for argon2 password
+BuildRequires: pkgconfig(libsodium) >= 1.0.14
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Obsoletes: %{?scl_prefix}php-pecl-libsodium2 < 3
@@ -1061,9 +1059,6 @@ echo '%%%{?scl:%{scl}_}pecl_xmldir %{_localstatedir}/lib/php/peclxml' | tee -a
# Some extensions have their own configuration file
cp %{SOURCE50} %{SOURCE51} %{SOURCE52} %{SOURCE53} .
-%ifarch x86_64
-sed -e '/opcache.huge_code_pages/s/0/1/' -i 10-opcache.ini
-%endif
sed -e 's:%{_root_sysconfdir}:%{_sysconfdir}:' \
-i 10-opcache.ini
@@ -1149,7 +1144,7 @@ ln -sf ../configure
--with-system-tzdata \
%endif
--with-mhash \
- --with-password-argon2 \
+ --without-password-argon2 \
%if %{with_dtrace}
--enable-dtrace \
%endif
@@ -1799,6 +1794,10 @@ fi
%changelog
+* Tue Jul 9 2019 Remi Collet <remi@remirepo.net> - 7.4.0~alpha3-12
+- update to 7.4.0alpha3
+- drop argon2 dependency using libsodium implementation
+
* Tue Jun 25 2019 Remi Collet <remi@remirepo.net> - 7.4.0~alpha2-11
- update to 7.4.0alpha2