From f1735bdbf5c52573a480f94c52679c9e6e1b7844 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Tue, 10 Sep 2019 16:43:35 +0200
Subject: v7.3.10RC1

---
 c43fc204b1639a8aa6c6212202def29b3c4cf611.patch | 32 ++++++++++++++++++++++++++
 failed.txt                                     |  6 +++--
 php.spec                                       | 13 ++++++++---
 3 files changed, 46 insertions(+), 5 deletions(-)
 create mode 100644 c43fc204b1639a8aa6c6212202def29b3c4cf611.patch

diff --git a/c43fc204b1639a8aa6c6212202def29b3c4cf611.patch b/c43fc204b1639a8aa6c6212202def29b3c4cf611.patch
new file mode 100644
index 0000000..c641f80
--- /dev/null
+++ b/c43fc204b1639a8aa6c6212202def29b3c4cf611.patch
@@ -0,0 +1,32 @@
+From c43fc204b1639a8aa6c6212202def29b3c4cf611 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@php.net>
+Date: Tue, 10 Sep 2019 16:28:35 +0200
+Subject: [PATCH] Raise minimal GCC version, Test with 4.8 is OK With 4.4:
+ error: #pragma GCC diagnostic not allowed inside functions
+
+---
+ ext/intl/idn/idn.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/intl/idn/idn.c b/ext/intl/idn/idn.c
+index 60d7b829d84e..96eac77048a0 100644
+--- a/ext/intl/idn/idn.c
++++ b/ext/intl/idn/idn.c
+@@ -226,7 +226,7 @@ static void php_intl_idn_to(INTERNAL_FUNCTION_PARAMETERS,
+ #if defined(__clang__)
+ # pragma clang diagnostic push
+ # pragma clang diagnostic ignored "-Wdeprecated-declarations"
+-#elif ZEND_GCC_VERSION >= 4002
++#elif ZEND_GCC_VERSION >= 4008
+ # pragma GCC diagnostic push
+ # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
+ #endif
+@@ -237,7 +237,7 @@ static void php_intl_idn_to(INTERNAL_FUNCTION_PARAMETERS,
+ 		}
+ #if defined(__clang__)
+ # pragma clang diagnostic pop
+-#elif ZEND_GCC_VERSION >= 4002
++#elif ZEND_GCC_VERSION >= 4008
+ # pragma GCC diagnostic pop
+ #endif
+ 		efree(ustring);
diff --git a/failed.txt b/failed.txt
index 56ced77..c834013 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,17 +1,19 @@
-===== 7.3.9 (2019-08-29)
+===== 7.3.10RC1 (2019-09-12)
 
 $ grep -ar 'Tests failed' /var/lib/mock/scl73*/build.log
 
 /var/lib/mock/scl73el6x/build.log:Tests failed    :     0
 /var/lib/mock/scl73el7x/build.log:Tests failed    :     0
 /var/lib/mock/scl73el8x/build.log:Tests failed    :    13
-/var/lib/mock/scl73fc28x/build.log:Tests failed    :    0
 /var/lib/mock/scl73fc29x/build.log:Tests failed    :    0
 /var/lib/mock/scl73fc30x/build.log:Tests failed    :    0
+/var/lib/mock/scl73fc31x/build.log:Tests failed    :    0
 
 
 el8x
 	5	buildroot issue (openssl)
+el7x, fc29x, fc30x
+	2	Bug #73837: Milliseconds in DateTime() [ext/date/tests/bug73837.phpt]
 
 
 (1)	proc_open give erratic test results :(
diff --git a/php.spec b/php.spec
index f70fc09..ebec537 100644
--- a/php.spec
+++ b/php.spec
@@ -131,8 +131,8 @@
 %global db_devel  libdb-devel
 %endif
 
-%global upver        7.3.9
-#global rcver        RC1
+%global upver        7.3.10
+%global rcver        RC1
 
 Summary: PHP scripting language for creating dynamic web sites
 Name:    %{?scl_prefix}php
@@ -192,6 +192,7 @@ Patch48: php-7.3.3-pdooci.patch
 Patch91: php-7.2.0-oci8conf.patch
 
 # Upstream fixes (100+)
+Patch100: https://github.com/php/php-src/commit/c43fc204b1639a8aa6c6212202def29b3c4cf611.patch
 
 # Security fixes (200+)
 
@@ -219,7 +220,7 @@ BuildRequires: zlib-devel, smtpdaemon, libedit-devel
 %if %{with_libpcre}
 BuildRequires: pcre2-devel >= 10.30
 %else
-Provides:      Provides: bundled(pcre2) = 10.32
+Provides:      bundled(pcre2) = 10.32
 %endif
 BuildRequires: bzip2
 BuildRequires: perl
@@ -952,6 +953,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
 %patch91 -p1 -b .remi-oci8
 
 # upstream patches
+%patch100 -p1 -b .up
 
 # security patches
 
@@ -993,6 +995,8 @@ rm ext/date/tests/bug33414-1.phpt
 rm ext/date/tests/bug33415-2.phpt
 rm ext/date/tests/date_modify-1.phpt
 %endif
+# too fast builder
+rm ext/date/tests/bug73837.phpt
 # fails sometime
 rm ext/sockets/tests/mcast_ipv?_recv.phpt
 # Should be skipped but fails sometime
@@ -1891,6 +1895,9 @@ fi
 
 
 %changelog
+* Tue Sep 10 2019 Remi Collet <remi@remirepo.net> - 7.3.10~RC1-1
+- update to 7.3.10RC1
+
 * Wed Aug 28 2019 Remi Collet <remi@remirepo.net> - 7.3.9-1
 - Update to 7.3.9 - http://www.php.net/releases/7_3_9.php
 
-- 
cgit