summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec28
1 files changed, 19 insertions, 9 deletions
diff --git a/php.spec b/php.spec
index 3e0f500..ddff81a 100644
--- a/php.spec
+++ b/php.spec
@@ -129,14 +129,14 @@
%global db_devel libdb-devel
%endif
-%global upver 7.3.1
-#global rcver RC1
-#global lower RC1
+%global upver 7.3.2
+%global rcver RC1
+%global lower RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 3%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -175,7 +175,7 @@ Patch9: php-7.0.7-curl.patch
# Functional changes
Patch40: php-7.2.4-dlopen.patch
-Patch42: php-7.2.3-systzdata-v16.patch
+Patch42: php-7.3.2-systzdata-v17.patch
# See http://bugs.php.net/53436
Patch43: php-7.3.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -197,7 +197,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.0.10-datetests.patch
# WIP
-Patch400: php-bug77430.patch
+Patch400: php-bug77287.patch
BuildRequires: bzip2-devel, curl-devel >= 7.9, %{db_devel}
BuildRequires: httpd-devel >= 2.0.46-1, pam-devel
@@ -919,7 +919,7 @@ low-level PHP extension for the libsodium cryptographic library.
%endif
%patch40 -p1 -b .dlopen
-%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 6
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
@@ -939,7 +939,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch300 -p1 -b .datetests
# WIP patch
-%patch400 -p1 -b .77430
+%patch400 -p1 -b .bug77287
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -968,6 +968,12 @@ mkdir \
rm ext/date/tests/timezone_location_get.phpt
rm ext/date/tests/timezone_version_get.phpt
rm ext/date/tests/timezone_version_get_basic1.phpt
+%if 0%{?fedora} < 28
+# need tzdata 2018i
+rm ext/date/tests/bug33414-1.phpt
+rm ext/date/tests/bug33415-2.phpt
+rm ext/date/tests/date_modify-1.phpt
+%endif
# fails sometime
rm ext/sockets/tests/mcast_ipv?_recv.phpt
# Should be skipped but fails sometime
@@ -1150,7 +1156,7 @@ ln -sf ../configure
--with-layout=GNU \
--with-kerberos \
--with-libxml-dir=%{_root_prefix} \
-%if 0%{?fedora} >= 25 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 6
--with-system-tzdata \
%endif
--with-mhash \
@@ -1869,6 +1875,10 @@ fi
%changelog
+* Tue Jan 22 2019 Remi Collet <remi@remirepo.net> - 7.3.2~RC1-1
+- update to 7.3.2RC1
+- update system tzdata patch for timelib 2018.01
+
* Thu Jan 17 2019 Remi Collet <remi@remirepo.net> 7.3.1-3
- cleanup for EL-8