summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt16
-rw-r--r--php-bug78297.patch62
-rw-r--r--php.spec7
3 files changed, 11 insertions, 74 deletions
diff --git a/failed.txt b/failed.txt
index 3df1e9c..cf40d3e 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,19 +1,17 @@
-===== 7.3.8RC1 (2019-07-18)
+===== 7.3.8 (2019-08-01)
$ grep -ar 'Tests failed' /var/lib/mock/scl73*/build.log
-/var/lib/mock/scl73el6x/build.log:Tests failed : 1
-/var/lib/mock/scl73el7x/build.log:Tests failed : 1
-/var/lib/mock/scl73el8x/build.log:Tests failed : 14
-/var/lib/mock/scl73fc28x/build.log:Tests failed : 1
-/var/lib/mock/scl73fc29x/build.log:Tests failed : 1
-/var/lib/mock/scl73fc30x/build.log:Tests failed : 1
+/var/lib/mock/scl73el6x/build.log:Tests failed : 0
+/var/lib/mock/scl73el7x/build.log:Tests failed : 0
+/var/lib/mock/scl73el8x/build.log:Tests failed : 13
+/var/lib/mock/scl73fc28x/build.log:Tests failed : 0
+/var/lib/mock/scl73fc29x/build.log:Tests failed : 0
+/var/lib/mock/scl73fc30x/build.log:Tests failed : 0
el8x
5 buildroot issue (openssl)
-all
- 2 Zend/tests/bug78271.phpt
(1) proc_open give erratic test results :(
diff --git a/php-bug78297.patch b/php-bug78297.patch
deleted file mode 100644
index 396a161..0000000
--- a/php-bug78297.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From f3e71b3b730eabc2b12871b3a19dad815219bcb9 Mon Sep 17 00:00:00 2001
-From: Nikita Popov <nikita.ppv@gmail.com>
-Date: Tue, 16 Jul 2019 11:08:27 +0200
-Subject: [PATCH] Fixed bug #78297
-
-(cherry picked from commit 8a19fe29de77d7477d59db472dd6aadabd5ac249)
----
- NEWS | 5 +++++
- sapi/phpdbg/phpdbg_list.c | 1 +
- sapi/phpdbg/tests/bug78297.phpt | 16 ++++++++++++++++
- 3 files changed, 22 insertions(+)
- create mode 100644 sapi/phpdbg/tests/bug78297.phpt
-
-diff --git a/NEWS b/NEWS
-index ae6a3c5405d8..76e8f830a0bb 100644
---- a/NEWS
-+++ b/NEWS
-@@ -1,5 +1,10 @@
- PHP NEWS
- |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
-+?? ??? ????, PHP 7.3.8
-+
-+- Phpdbg:
-+ . Fixed bug #78297 (Include unexistent file memory leak). (Nikita)
-+
- 18 Jul 2019, PHP 7.3.8RC1
-
- - Core:
-diff --git a/sapi/phpdbg/phpdbg_list.c b/sapi/phpdbg/phpdbg_list.c
-index aab641cb5606..a9b0f4b815cf 100644
---- a/sapi/phpdbg/phpdbg_list.c
-+++ b/sapi/phpdbg/phpdbg_list.c
-@@ -248,6 +248,7 @@ zend_op_array *phpdbg_compile_file(zend_file_handle *file, int type) {
- } else {
- zend_message_dispatcher(ZMSG_FAILED_INCLUDE_FOPEN, file->filename);
- }
-+ return NULL;
- }
-
- data.buf = estrndup(bufptr, len);
-diff --git a/sapi/phpdbg/tests/bug78297.phpt b/sapi/phpdbg/tests/bug78297.phpt
-new file mode 100644
-index 000000000000..47b13ad60544
---- /dev/null
-+++ b/sapi/phpdbg/tests/bug78297.phpt
-@@ -0,0 +1,16 @@
-+--TEST--
-+Bug #78297: Include unexistent file memory leak
-+--PHPDBG--
-+r
-+q
-+--FILE--
-+<?php
-+include "does_not_exist.php";
-+--EXPECTF--
-+[Successful compilation of %s]
-+prompt>
-+Warning: include(%s): failed to open stream: No such file or directory in %s on line %d
-+
-+Warning: include(): Failed opening 'does_not_exist.php' for inclusion (include_path=%s) in %s on line %d
-+[Script ended normally]
-+prompt>
diff --git a/php.spec b/php.spec
index 6058e99..421324a 100644
--- a/php.spec
+++ b/php.spec
@@ -132,7 +132,7 @@
%endif
%global upver 7.3.8
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -192,7 +192,6 @@ Patch48: php-7.3.3-pdooci.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-bug78297.patch
# Security fixes (200+)
@@ -953,7 +952,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .78297
# security patches
@@ -1893,6 +1891,9 @@ fi
%changelog
+* Tue Jul 30 2019 Remi Collet <remi@remirepo.net> - 7.3.8-1
+- Update to 7.3.8 - http://www.php.net/releases/7_3_8.php
+
* Tue Jul 16 2019 Remi Collet <remi@remirepo.net> - 7.3.8~RC1-1
- update to 7.3.8RC1
- add upstream patch for #78297