summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cd0a37994e3cbf1f0aa1174155d3d662cefe2e7a.patch38
-rw-r--r--failed.txt4
-rw-r--r--php.spec9
3 files changed, 46 insertions, 5 deletions
diff --git a/cd0a37994e3cbf1f0aa1174155d3d662cefe2e7a.patch b/cd0a37994e3cbf1f0aa1174155d3d662cefe2e7a.patch
new file mode 100644
index 0000000..0cb89c8
--- /dev/null
+++ b/cd0a37994e3cbf1f0aa1174155d3d662cefe2e7a.patch
@@ -0,0 +1,38 @@
+From cd0a37994e3cbf1f0aa1174155d3d662cefe2e7a Mon Sep 17 00:00:00 2001
+From: Jakub Zelenka <bukka@php.net>
+Date: Sun, 2 Sep 2018 20:00:08 +0100
+Subject: [PATCH] Fix stream_security_level.phpt with OpenSSL 1.1.1
+
+---
+ ext/openssl/tests/stream_security_level.phpt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/ext/openssl/tests/stream_security_level.phpt b/ext/openssl/tests/stream_security_level.phpt
+index fb1d36a58624..26fedcf670e9 100644
+--- a/ext/openssl/tests/stream_security_level.phpt
++++ b/ext/openssl/tests/stream_security_level.phpt
+@@ -5,6 +5,7 @@ security_level setting to prohibit cert
+ if (!extension_loaded("openssl")) die("skip openssl not loaded");
+ if (OPENSSL_VERSION_NUMBER < 0x10100000) die("skip OpenSSL >= v1.1.0 required");
+ if (!function_exists("proc_open")) die("skip no proc_open");
++?>
+ --FILE--
+ <?php
+ $serverCode = <<<'CODE'
+@@ -24,7 +25,7 @@ $clientCode = <<<'CODE'
+ $serverUri = "ssl://127.0.0.1:64322";
+ $clientFlags = STREAM_CLIENT_CONNECT;
+ $clientCtx = stream_context_create(['ssl' => [
+- 'security_level' => 3,
++ 'security_level' => 2,
+ 'verify_peer' => true,
+ 'cafile' => __DIR__ . '/bug54992-ca.pem',
+ 'verify_peer_name' => false
+@@ -38,6 +39,7 @@ CODE;
+
+ include 'ServerClientTestCase.inc';
+ ServerClientTestCase::getInstance()->run($clientCode, $serverCode);
++?>
+ --EXPECTF--
+ Warning: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
+ error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed in %s : eval()'d code on line %d
diff --git a/failed.txt b/failed.txt
index 7d76e82..2019b9e 100644
--- a/failed.txt
+++ b/failed.txt
@@ -6,11 +6,9 @@ $ grep -r 'Tests failed' /var/lib/mock/scl73*/build.log
/var/lib/mock/scl72el7x/build.log:Tests failed : 0
/var/lib/mock/scl72fc27x/build.log:Tests failed : 0
/var/lib/mock/scl72fc28x/build.log:Tests failed : 0
-/var/lib/mock/scl73fc29x/build.log:Tests failed : 1
+/var/lib/mock/scl73fc29x/build.log:Tests failed : 0
-fc29x
- security_level setting to prohibit cert [ext/openssl/tests/stream_security_level.phpt]
(1) proc_open give erratic test results :(
diff --git a/php.spec b/php.spec
index f973036..18c623b 100644
--- a/php.spec
+++ b/php.spec
@@ -130,7 +130,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -184,6 +184,7 @@ Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
Patch100: php-upstream.patch
+Patch101: https://github.com/php/php-src/commit/cd0a37994e3cbf1f0aa1174155d3d662cefe2e7a.patch
# Security fixes (200+)
@@ -924,7 +925,8 @@ low-level PHP extension for the libsodium cryptographic library.
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
+%patch100 -p1 -b .up1
+%patch101 -p1 -b .up2
# security patches
@@ -1859,6 +1861,9 @@ fi
%changelog
+* Mon Sep 3 2018 Remi Collet <remi@remirepo.net> - 7.3.0~beta3-3
+- add upstream patch for openssl failing test
+
* Tue Aug 28 2018 Remi Collet <remi@remirepo.net> - 7.3.0~beta3-2
- add upstream patch for F29