summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-bug77430.patch36
-rw-r--r--php.spec7
2 files changed, 42 insertions, 1 deletions
diff --git a/php-bug77430.patch b/php-bug77430.patch
new file mode 100644
index 0000000..17c1ad1
--- /dev/null
+++ b/php-bug77430.patch
@@ -0,0 +1,36 @@
+diff --git a/sapi/fpm/fpm/fpm_stdio.c b/sapi/fpm/fpm/fpm_stdio.c
+index ba8f6d8213..03d15cbf0d 100644
+--- a/sapi/fpm/fpm/fpm_stdio.c
++++ b/sapi/fpm/fpm/fpm_stdio.c
+@@ -122,7 +122,7 @@ static void fpm_stdio_child_said(struct fpm_event_s *ev, short which, void *arg)
+ struct fpm_event_s *event;
+ int fifo_in = 1, fifo_out = 1;
+ int in_buf = 0;
+- int read_fail = 0, finish_log_stream = 0;
++ int read_fail = 0, finish_log_stream = 0, create_log_stream;
+ int res;
+ struct zlog_stream *log_stream;
+
+@@ -138,7 +138,8 @@ static void fpm_stdio_child_said(struct fpm_event_s *ev, short which, void *arg)
+ event = &child->ev_stderr;
+ }
+
+- if (!child->log_stream) {
++ create_log_stream = !child->log_stream;
++ if (create_log_stream) {
+ log_stream = child->log_stream = malloc(sizeof(struct zlog_stream));
+ zlog_stream_init_ex(log_stream, ZLOG_WARNING, STDERR_FILENO);
+ zlog_stream_set_decorating(log_stream, child->wp->config->decorate_workers_output);
+@@ -196,8 +197,10 @@ static void fpm_stdio_child_said(struct fpm_event_s *ev, short which, void *arg)
+ }
+
+ if (read_fail) {
+- zlog_stream_set_msg_suffix(log_stream, NULL, ", pipe is closed");
+- zlog_stream_finish(log_stream);
++ if (create_log_stream) {
++ zlog_stream_set_msg_suffix(log_stream, NULL, ", pipe is closed");
++ zlog_stream_finish(log_stream);
++ }
+ if (read_fail < 0) {
+ zlog(ZLOG_SYSERROR, "unable to read what child say");
+ }
diff --git a/php.spec b/php.spec
index 0205cc6..eff0fa7 100644
--- a/php.spec
+++ b/php.spec
@@ -131,7 +131,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{lower}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -192,6 +192,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.0.10-datetests.patch
# WIP
+Patch400: php-bug77430.patch
BuildRequires: bzip2-devel, curl-devel >= 7.9, %{db_devel}
BuildRequires: httpd-devel >= 2.0.46-1, pam-devel
@@ -933,6 +934,7 @@ low-level PHP extension for the libsodium cryptographic library.
%patch300 -p1 -b .datetests
# WIP patch
+%patch400 -p1 -b .77430
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1862,6 +1864,9 @@ fi
%changelog
+* Wed Jan 16 2019 Remi Collet <remi@remirepo.net> - 7.3.1-2
+- test build for https://bugs.php.net/77430
+
* Tue Jan 8 2019 Remi Collet <remi@remirepo.net> - 7.3.1-1
- Update to 7.3.1 - http://www.php.net/releases/7_3_1.php