summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec20
1 files changed, 11 insertions, 9 deletions
diff --git a/php.spec b/php.spec
index c8fe559..11c3dfe 100644
--- a/php.spec
+++ b/php.spec
@@ -26,7 +26,7 @@
%global zendver 20170718
%global pdover 20170320
# Extension version
-%global oci8ver 2.1.8
+%global oci8ver 2.2.0
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -124,13 +124,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.2.13
-#global rcver RC1
+%global upver 7.2.14
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -187,7 +187,6 @@ Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
# Security fixes (200+)
-Patch200: php-imap.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -606,10 +605,10 @@ BuildRequires: oracle-instantclient-devel >= %{oraclever}
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_oci, %{?scl_prefix}php-pdo_oci%{?_isa}
-Obsoletes: %{?scl_prefix}php-pecl-oci8 < %{oci8ver}
-Conflicts: %{?scl_prefix}php-pecl-oci8 >= %{oci8ver}
+Obsoletes: %{?scl_prefix}php-pecl-oci8 <= %{oci8ver}
+Conflicts: %{?scl_prefix}php-pecl-oci8 > %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8) = %{oci8ver}, %{?scl_prefix}php-pecl(oci8)%{?_isa} = %{oci8ver}
-# Should requires libclntsh.so.12.1, but it's not provided by Oracle RPM.
+# Should requires libclntsh.so.18.3, but it's not provided by Oracle RPM.
AutoReq: 0
%description oci8
@@ -931,7 +930,6 @@ low-level PHP extension for the libsodium cryptographic library.
# upstream patches
# security patches
-%patch200 -p1 -b .imap
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -1872,6 +1870,10 @@ fi
%changelog
+* Tue Dec 18 2018 Remi Collet <remi@remirepo.net> - 7.2.14~RC1-1
+- update to 7.2.14RC1
+- oci8 version is now 2.2.0
+
* Sat Dec 8 2018 Remi Collet <remi@remirepo.net> - 7.2.13-2
- Fix null pointer dereference in imap_mail CVE-2018-19935