summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec58
1 files changed, 23 insertions, 35 deletions
diff --git a/php.spec b/php.spec
index ef731f1..1b3f4f8 100644
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php71-php
+# remirepo spec file for php72-php
# with SCL and backport stuff, adapted from
#
# Fedora spec file for php
@@ -22,17 +22,17 @@
%endif
# API/ABI check
-%global apiver 20160303
+%global apiver 20160731
%global zendver 20160303
-%global pdover 20150127
+%global pdover 20170320
# Extension version
-%global oci8ver 2.1.3
+%global oci8ver 2.1.4
# Adds -z now to the linker flags
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 7.1
+%global embed_version 7.2
# Ugly hack. Harcoded values to avoid relocation.
%global _httpd_mmn %(cat %{_root_includedir}/httpd/.mmn 2>/dev/null || echo 0)
@@ -72,7 +72,6 @@
%global with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
%global with_imap 1
%global with_interbase 1
-%global with_mcrypt 1
%global with_freetds 1
%global with_tidy 1
%global with_sqlite3 1
@@ -124,14 +123,23 @@
%global db_devel libdb-devel
%endif
+%global gh_commit efeab78535008a4640896624a1ceb8af8615535d
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_date 20170412
+%global gh_owner php
+%global gh_project php-src
#global rcver RC1
%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.1.4
+Version: 7.2.0
+%if 0%{?gh_date}
+Release: 0.%{rpmrel}.%{gh_date}.%{gh_short}%{?dist}
+%else
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
+%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -163,7 +171,7 @@ Source51: opcache-default.blacklist
Source52: 20-oci8.ini
# Build fixes
-Patch5: php-7.0.0-includedir.patch
+Patch5: php-7.2.0-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-7.0.2-libdb.patch
@@ -177,7 +185,7 @@ Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.6.3-ldap_r.patch
# Make php_config.h constant across builds
-Patch46: php-7.0.0-fixheader.patch
+Patch46: php-7.2.0-fixheader.patch
# drop "Configure command" from phpinfo output
Patch47: php-5.6.3-phpinfo.patch
@@ -734,20 +742,6 @@ Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
The %{?scl_prefix}php-dba package contains a dynamic shared object that will add
support for using the DBA database abstraction layer to PHP.
-%if %{with_mcrypt}
-%package mcrypt
-Summary: Standard PHP module provides mcrypt library support
-Group: Development/Languages
-# All files licensed under PHP version 3.01
-License: PHP
-Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: libmcrypt-devel
-
-%description mcrypt
-The %{?scl_prefix}php-mcrypt package contains a dynamic shared object that will add
-support for using the mcrypt library to PHP.
-%endif
-
%if %{with_tidy}
%package tidy
Summary: Standard PHP module provides tidy library support
@@ -862,7 +856,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%prep
-: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} mcrypt=%{with_mcrypt} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
+: Building %{name}-%{version}-%{release} with systemd=%{with_systemd} imap=%{with_imap} interbase=%{with_interbase} freetds=%{with_freetds} sqlite3=%{with_sqlite3} tidy=%{with_tidy} zip=%{with_zip}
%if 0%{?gh_date}
%setup -q -n %{gh_project}-%{gh_commit}
%else
@@ -1060,7 +1054,7 @@ cat $(aclocal --print-ac-dir)/libtool.m4 > build/libtool.m4
%endif
# Regenerate configure scripts (patches change config.m4's)
-touch configure.in
+touch configure.ac
./buildconf --force
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
@@ -1103,7 +1097,6 @@ ln -sf ../configure
--with-freetype-dir=%{_root_prefix} \
--with-png-dir=%{_root_prefix} \
--with-xpm-dir=%{_root_prefix} \
- --enable-gd-native-ttf \
--without-gdbm \
--with-jpeg-dir=%{_root_prefix} \
--with-openssl \
@@ -1211,9 +1204,6 @@ build --libdir=%{_libdir}/php \
--with-libedit \
--with-pspell=shared \
--enable-phar=shared \
-%if %{with_mcrypt}
- --with-mcrypt=shared,%{_root_prefix} \
-%endif
%if %{with_tidy}
--with-tidy=shared,%{_root_prefix} \
%endif
@@ -1484,9 +1474,6 @@ for mod in pgsql odbc ldap snmp xmlrpc \
enchant \
%endif
phar fileinfo intl \
-%if %{with_mcrypt}
- mcrypt \
-%endif
%if %{with_tidy}
tidy \
%endif
@@ -1779,9 +1766,6 @@ fi
%files gmp -f files.gmp
%files dba -f files.dba
%files pdo -f files.pdo
-%if %{with_mcrypt}
-%files mcrypt -f files.mcrypt
-%endif
%if %{with_tidy}
%files tidy -f files.tidy
%endif
@@ -1813,6 +1797,10 @@ fi
%changelog
+* Wed Apr 12 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.1.20170412.efeab78
+- update to 7.2.0-dev
+- drop mcrypt subpackage (removed upstream)
+
* Tue Apr 11 2017 Remi Collet <remi@fedoraproject.org> - 7.1.4-1
- Update to 7.1.4 - http://www.php.net/releases/7_1_4.php