summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-7.2.0-systzdata-v15.patch (renamed from php-7.1.0-systzdata-v14.patch)102
-rw-r--r--php.spec14
2 files changed, 48 insertions, 68 deletions
diff --git a/php-7.1.0-systzdata-v14.patch b/php-7.2.0-systzdata-v15.patch
index bd73a4b..97fd734 100644
--- a/php-7.1.0-systzdata-v14.patch
+++ b/php-7.2.0-systzdata-v15.patch
@@ -5,6 +5,7 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
+r15: adapt for timelib 2017.05beta7 (in 7.2.0RC1)
r14: improve check for valid tz file
r13: adapt for upstream changes to use PHP allocator
r12: adapt for upstream changes for new zic
@@ -25,12 +26,12 @@ r3: fix a crash if /usr/share/zoneinfo doesn't exist (Raphael Geissert)
r2: add filesystem trawl to set up name alias index
r1: initial revision
-diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/lib/parse_tz.c
---- php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata 2016-10-17 13:35:11.000000000 +0200
-+++ php-7.1.0RC4/ext/date/lib/parse_tz.c 2016-10-17 13:40:47.806358674 +0200
-@@ -24,6 +24,16 @@
-
+diff -up ./ext/date/lib/parse_tz.c.systzdata ./ext/date/lib/parse_tz.c
+--- ./ext/date/lib/parse_tz.c.systzdata 2017-08-22 09:40:38.000000000 +0200
++++ ./ext/date/lib/parse_tz.c 2017-08-22 12:16:00.370298079 +0200
+@@ -25,8 +25,21 @@
#include "timelib.h"
+ #include "timelib_private.h"
+#ifdef HAVE_SYSTEM_TZDATA
+#include <sys/mman.h>
@@ -40,16 +41,8 @@ diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/li
+#include <unistd.h>
+
+#include "php_scandir.h"
-+#endif
+
- #include <stdio.h>
-
- #ifdef HAVE_LOCALE_H
-@@ -36,8 +46,12 @@
- #include <strings.h>
- #endif
-
-+#ifndef HAVE_SYSTEM_TZDATA
++#else
#define TIMELIB_SUPPORTS_V2DATA
#include "timezonedb.h"
+#endif
@@ -58,7 +51,7 @@ diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/li
#if (defined(__APPLE__) || defined(__APPLE_CC__)) && (defined(__BIG_ENDIAN__) || defined(__LITTLE_ENDIAN__))
# if defined(__LITTLE_ENDIAN__)
-@@ -59,6 +73,11 @@ static int read_preamble(const unsigned
+@@ -67,6 +80,11 @@ static int read_php_preamble(const unsig
{
uint32_t version;
@@ -70,7 +63,7 @@ diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/li
/* read ID */
version = (*tzf)[3] - '0';
*tzf += 4;
-@@ -302,7 +321,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
+@@ -374,7 +392,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
}
}
@@ -501,7 +494,7 @@ diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/li
{
int left = 0, right = tzdb->index_size - 1;
#ifdef HAVE_SETLOCALE
-@@ -341,21 +782,88 @@ static int seek_to_tz_position(const uns
+@@ -419,9 +859,48 @@ static int seek_to_tz_position(const uns
return 0;
}
@@ -549,17 +542,8 @@ diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/li
+#endif
}
- const timelib_tzdb_index_entry *timelib_timezone_builtin_identifiers_list(int *count)
- {
-+#ifdef HAVE_SYSTEM_TZDATA
-+ *count = timezonedb_system->index_size;
-+ return timezonedb_system->index;
-+#else
- *count = sizeof(timezonedb_idx_builtin) / sizeof(*timezonedb_idx_builtin);
- return timezonedb_idx_builtin;
-+#endif
- }
-
+ const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(timelib_tzdb *tzdb, int *count)
+@@ -433,7 +912,30 @@ const timelib_tzdb_index_entry *timelib_
int timelib_timezone_id_is_valid(char *timezone, const timelib_tzdb *tzdb)
{
const unsigned char *tzf;
@@ -590,32 +574,27 @@ diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/li
+ return (inmem_seek_to_tz_position(&tzf, timezone, tzdb));
}
- static void skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
-@@ -380,24 +888,54 @@ static void read_64bit_header(const unsi
- timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb)
+ static int skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
+@@ -475,12 +977,14 @@ static timelib_tzinfo* timelib_tzinfo_ct
+ timelib_tzinfo *timelib_parse_tzfile(char *timezone, const timelib_tzdb *tzdb, int *error_code)
{
const unsigned char *tzf;
+ char *memmap = NULL;
+ size_t maplen;
timelib_tzinfo *tmp;
int version;
+ int transitions_result, types_result;
+ unsigned int type; /* TIMELIB_TZINFO_PHP or TIMELIB_TZINFO_ZONEINFO */
- if (seek_to_tz_position(&tzf, timezone, tzdb)) {
+ if (seek_to_tz_position(&tzf, timezone, &memmap, &maplen, tzdb)) {
tmp = timelib_tzinfo_ctor(timezone);
- version = read_preamble(&tzf, tmp);
- read_header(&tzf, tmp);
- read_transistions(&tzf, tmp);
- read_types(&tzf, tmp);
-- if (version == 2) {
-- skip_64bit_preamble(&tzf, tmp);
-- read_64bit_header(&tzf, tmp);
-- skip_64bit_transistions(&tzf, tmp);
-- skip_64bit_types(&tzf, tmp);
-- skip_posix_string(&tzf, tmp);
-- }
-- read_location(&tzf, tmp);
+ version = read_preamble(&tzf, tmp, &type);
+@@ -503,6 +1007,29 @@ timelib_tzinfo *timelib_parse_tzfile(cha
+ timelib_tzinfo_dtor(tmp);
+ return NULL;
+ }
+
+#ifdef HAVE_SYSTEM_TZDATA
+ if (memmap) {
@@ -632,33 +611,30 @@ diff -up php-7.1.0RC4/ext/date/lib/parse_tz.c.systzdata php-7.1.0RC4/ext/date/li
+ tmp->bc = 1;
+ }
+ else {
-+ strcpy(tmp->location.country_code, "??");
-+ tmp->bc = 0;
-+ tmp->location.comments = timelib_strdup("");
++ set_default_location_and_comments(&tzf, tmp);
+ }
+
+ /* Now done with the mmap segment - discard it. */
+ munmap(memmap, maplen);
-+ } else
++ } else {
++#endif
+ if (version == 2 || version == 3) {
+ if (!skip_64bit_preamble(&tzf, tmp)) {
+ /* 64 bit preamble is not in place */
+@@ -520,6 +1047,9 @@ timelib_tzinfo *timelib_parse_tzfile(cha
+ } else {
+ set_default_location_and_comments(&tzf, tmp);
+ }
++#ifdef HAVE_SYSTEM_TZDATA
++ }
+#endif
-+ {
-+ /* PHP-style - use the embedded info. */
-+ if (version == 2) {
-+ skip_64bit_preamble(&tzf, tmp);
-+ read_64bit_header(&tzf, tmp);
-+ skip_64bit_transistions(&tzf, tmp);
-+ skip_64bit_types(&tzf, tmp);
-+ skip_posix_string(&tzf, tmp);
-+ }
-+ read_location(&tzf, tmp);
-+ }
} else {
+ *error_code = TIMELIB_ERROR_NO_SUCH_TIMEZONE;
tmp = NULL;
- }
-diff -up php-7.1.0RC4/ext/date/lib/timelib.m4.systzdata php-7.1.0RC4/ext/date/lib/timelib.m4
---- php-7.1.0RC4/ext/date/lib/timelib.m4.systzdata 2016-10-17 13:40:47.807358679 +0200
-+++ php-7.1.0RC4/ext/date/lib/timelib.m4 2016-10-17 13:42:06.304743330 +0200
-@@ -78,3 +78,16 @@ stdlib.h
+diff -up ./ext/date/lib/timelib.m4.systzdata ./ext/date/lib/timelib.m4
+--- ./ext/date/lib/timelib.m4.systzdata 2017-08-22 09:40:38.000000000 +0200
++++ ./ext/date/lib/timelib.m4 2017-08-22 11:32:29.357799927 +0200
+@@ -81,3 +81,16 @@ io.h
dnl Check for strtoll, atoll
AC_CHECK_FUNCS(strtoll atoll strftime gettimeofday)
diff --git a/php.spec b/php.spec
index b442cec..d9bd06e 100644
--- a/php.spec
+++ b/php.spec
@@ -128,13 +128,13 @@
%global db_devel libdb-devel
%endif
-%global gh_commit 249f75e7e423ce858827c1d13231e1f762a9b267
+%global gh_commit 3fff74aab5e41195cded72ca705de015abfd710a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20170711
+%global gh_date 20170822
%global gh_owner php
%global gh_project php-src
-%global rcver beta3
-%global rpmrel 16
+#global rcver beta3
+%global rpmrel 17
Summary: PHP scripting language for creating dynamic web sites
@@ -184,7 +184,7 @@ Patch9: php-7.0.7-curl.patch
# Functional changes
Patch40: php-7.1.3-dlopen.patch
-Patch42: php-7.1.0-systzdata-v14.patch
+Patch42: php-7.2.0-systzdata-v15.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -1847,6 +1847,10 @@ fi
%changelog
+* Tue Aug 22 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.17.20170822.3fff74a.
+- test build from git snapshot
+- adapt tzdata patch for timelib 2017.05beta7
+
* Tue Aug 15 2017 Remi Collet <remi@remirepo.net> - 7.2.0-0.16.beta3
- update to 7.2.0beta3