summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-27 16:30:30 +0200
committerRemi Collet <remi@php.net>2022-09-27 16:30:30 +0200
commite3bbc962c4f294896bf44d5b74e9c9feecaa12cc (patch)
treee984ef567b53a8a15f7e08ec9fd90351254838a5 /php.spec
parent7175a6b5b9e8c83736bf450537d7be76f8455344 (diff)
phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
core: fix #81727 Don't mangle HTTP variable names that clash with ones that have a specific semantic meaning. CVE-2022-31629 use oracle client library version 21.7
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php.spec b/php.spec
index 1ce12fb..b675beb 100644
--- a/php.spec
+++ b/php.spec
@@ -55,7 +55,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.6
+%global oraclever 21.7
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -126,7 +126,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 11%{?dist}
+Release: 12%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -202,6 +202,8 @@ Patch206: php-bug81026.patch
Patch207: php-bug79971.patch
Patch208: php-bug81719.patch
Patch209: php-bug81720.patch
+Patch210: php-bug81727.patch
+Patch211: php-bug81726.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -313,7 +315,6 @@ The %{?scl_prefix}php-dbg package contains the interactive PHP debugger.
Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
-Requires(pre): %{_root_sbindir}/useradd
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
%if %{with_systemd}
BuildRequires: systemd-devel
@@ -333,6 +334,8 @@ Requires(pre): httpd-filesystem
# For php.conf in /etc/httpd/conf.d
# and version 2.4.10 for proxy support in SetHandler
Requires: httpd-filesystem >= 2.4.10
+%else
+Requires(pre): %{_root_sbindir}/useradd
%endif
%description fpm
@@ -851,8 +854,8 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-# Upstream requires 4.0, we require 50 to ensure use of libicu-last / libicu62
-BuildRequires: libicu-devel >= 69
+# Upstream requires 4.0, we require 69.1 to ensure use of libicu69
+BuildRequires: libicu-devel = 69.1
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -970,6 +973,8 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch207 -p1 -b .bug79971
%patch208 -p1 -b .bug81719
%patch209 -p1 -b .bug81720
+%patch210 -p1 -b .bug81727
+%patch211 -p1 -b .bug81726
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -1940,6 +1945,12 @@ EOF
%changelog
+* Tue Sep 27 2022 Remi Collet <remi@remirepo.net> - 7.2.34-12
+- phar: fix #81726 DOS when using quine gzip file. CVE-2022-31628
+- core: fix #81727 Don't mangle HTTP variable names that clash with ones
+ that have a specific semantic meaning. CVE-2022-31629
+- use oracle client library version 21.7
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.2.34-11
- use oracle client library version 21.6
- mysqlnd: fix #81719: mysqlnd/pdo password buffer overflow. CVE-2022-31626