summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-18 14:17:35 +0100
committerRemi Collet <remi@remirepo.net>2018-12-18 14:17:35 +0100
commitcfffa4fca34a10c7667c1b33ab39bddc565f5e71 (patch)
tree8e7ce05a65890ff5fee1c8b7d6f1ae584941673d
parentf573c466a61227362b1718c503a2b4e114b7179a (diff)
update to 7.2.14RC1
oci8 version is now 2.2.0
-rw-r--r--failed.txt2
-rw-r--r--php-imap.patch71
-rw-r--r--php.spec20
3 files changed, 12 insertions, 81 deletions
diff --git a/failed.txt b/failed.txt
index 1657d7c..2165b58 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 7.2.13 (2018-12-06)
+===== 7.2.14RC1 (2018-12-20)
$ grep -r 'Tests failed' /var/lib/mock/scl72*/build.log
diff --git a/php-imap.patch b/php-imap.patch
deleted file mode 100644
index 81c2b7c..0000000
--- a/php-imap.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From d8765852e0400ee2ce8ae9e2177c42731d4539d8 Mon Sep 17 00:00:00 2001
-From: Stanislav Malyshev <stas@php.net>
-Date: Wed, 28 Nov 2018 15:45:51 -0800
-Subject: [PATCH] Add DISPLAY_INI_ENTRIES for imap
-
----
- ext/imap/php_imap.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/ext/imap/php_imap.c b/ext/imap/php_imap.c
-index f6feebe9f769..a23e84c08521 100644
---- a/ext/imap/php_imap.c
-+++ b/ext/imap/php_imap.c
-@@ -1153,6 +1153,8 @@ PHP_MINFO_FUNCTION(imap)
- php_info_print_table_row(2, "Kerberos Support", "enabled");
- #endif
- php_info_print_table_end();
-+
-+ DISPLAY_INI_ENTRIES();
- }
- /* }}} */
-
-From 7edc639b9ff1c3576773d79d016abbeed1f93846 Mon Sep 17 00:00:00 2001
-From: Stanislav Malyshev <stas@php.net>
-Date: Sun, 11 Nov 2018 10:04:01 -0800
-Subject: [PATCH] Fix #77020: null pointer dereference in imap_mail
-
-If an empty $message is passed to imap_mail(), we must not set message
-to NULL, since _php_imap_mail() is not supposed to handle NULL pointers
-(opposed to pointers to NUL).
----
- NEWS | 1 +
- ext/imap/php_imap.c | 1 -
- ext/imap/tests/bug77020.phpt | 15 +++++++++++++++
- 3 files changed, 16 insertions(+), 1 deletion(-)
- create mode 100644 ext/imap/tests/bug77020.phpt
-
-diff --git a/ext/imap/php_imap.c b/ext/imap/php_imap.c
-index a23e84c08521..b30440f000f3 100644
---- a/ext/imap/php_imap.c
-+++ b/ext/imap/php_imap.c
-@@ -4125,7 +4125,6 @@ PHP_FUNCTION(imap_mail)
- if (!ZSTR_LEN(message)) {
- /* this is not really an error, so it is allowed. */
- php_error_docref(NULL, E_WARNING, "No message string in mail command");
-- message = NULL;
- }
-
- if (_php_imap_mail(ZSTR_VAL(to), ZSTR_VAL(subject), ZSTR_VAL(message), headers?ZSTR_VAL(headers):NULL, cc?ZSTR_VAL(cc):NULL,
-diff --git a/ext/imap/tests/bug77020.phpt b/ext/imap/tests/bug77020.phpt
-new file mode 100644
-index 000000000000..8a65232eec6d
---- /dev/null
-+++ b/ext/imap/tests/bug77020.phpt
-@@ -0,0 +1,15 @@
-+--TEST--
-+Bug #77020 (null pointer dereference in imap_mail)
-+--SKIPIF--
-+<?php
-+if (!extension_loaded('imap')) die('skip imap extension not available');
-+?>
-+--FILE--
-+<?php
-+imap_mail('1', 1, NULL);
-+?>
-+===DONE===
-+--EXPECTF--
-+Warning: imap_mail(): No message string in mail command in %s on line %d
-+%s
-+===DONE===
-
diff --git a/php.spec b/php.spec
index c8fe559..11c3dfe 100644
--- a/php.spec
+++ b/php.spec
@@ -26,7 +26,7 @@
%global zendver 20170718
%global pdover 20170320
# Extension version
-%global oci8ver 2.1.8
+%global oci8ver 2.2.0
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -124,13 +124,13 @@
%global db_devel libdb-devel
%endif
-%global upver 7.2.13
-#global rcver RC1
+%global upver 7.2.14
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -187,7 +187,6 @@ Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
# Security fixes (200+)
-Patch200: php-imap.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -606,10 +605,10 @@ BuildRequires: oracle-instantclient-devel >= %{oraclever}
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_oci, %{?scl_prefix}php-pdo_oci%{?_isa}
-Obsoletes: %{?scl_prefix}php-pecl-oci8 < %{oci8ver}
-Conflicts: %{?scl_prefix}php-pecl-oci8 >= %{oci8ver}
+Obsoletes: %{?scl_prefix}php-pecl-oci8 <= %{oci8ver}
+Conflicts: %{?scl_prefix}php-pecl-oci8 > %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8) = %{oci8ver}, %{?scl_prefix}php-pecl(oci8)%{?_isa} = %{oci8ver}
-# Should requires libclntsh.so.12.1, but it's not provided by Oracle RPM.
+# Should requires libclntsh.so.18.3, but it's not provided by Oracle RPM.
AutoReq: 0
%description oci8
@@ -931,7 +930,6 @@ low-level PHP extension for the libsodium cryptographic library.
# upstream patches
# security patches
-%patch200 -p1 -b .imap
# Fixes for tests
%patch300 -p1 -b .datetests
@@ -1872,6 +1870,10 @@ fi
%changelog
+* Tue Dec 18 2018 Remi Collet <remi@remirepo.net> - 7.2.14~RC1-1
+- update to 7.2.14RC1
+- oci8 version is now 2.2.0
+
* Sat Dec 8 2018 Remi Collet <remi@remirepo.net> - 7.2.13-2
- Fix null pointer dereference in imap_mail CVE-2018-19935