summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec13
1 files changed, 12 insertions, 1 deletions
diff --git a/php.spec b/php.spec
index a04d172..988c261 100644
--- a/php.spec
+++ b/php.spec
@@ -125,7 +125,7 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
%global rpmrel 1
@@ -1344,6 +1344,12 @@ make -C build-cgi install \
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/
install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
+%if %{with_libpcre}
+if ! pkg-config libpcre --atleast-version 8.38 ; then
+ sed -e 's/;pcre.jit=1/pcre.jit=0/' -i $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
+fi
+%endif
+
# For third-party packaging:
install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/php
@@ -1826,6 +1832,11 @@ fi
%changelog
+* Wed Mar 2 2016 Remi Collet <remi@fedoraproject.org> 7.0.4-1
+- Update to 7.0.4
+ http://www.php.net/releases/7_0_4.php
+- pcre: disables JIT compilation of patterns with system pcre < 8.38
+
* Thu Feb 18 2016 Remi Collet <remi@fedoraproject.org> 7.0.4-0.1.0RC1
- Update to 7.0.4RC1