summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--failed.txt8
-rw-r--r--php-5.5.30-curl.patch14
-rw-r--r--php-7.0.7-curl.patch15
-rw-r--r--php.spec14
4 files changed, 29 insertions, 22 deletions
diff --git a/failed.txt b/failed.txt
index 36e5d0b..ab424d0 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,17 +1,19 @@
-===== 7.0.6 (2016-04-28)
+===== 7.0.7RC1 (2016-05-12)
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
/var/lib/mock/scl70el6x/build.log:Tests failed : 2
-/var/lib/mock/scl70el7x/build.log:Tests failed : 2
+/var/lib/mock/scl70el7x/build.log:Tests failed : 3
/var/lib/mock/scl70fc21x/build.log:Tests failed : 0
/var/lib/mock/scl70fc22x/build.log:Tests failed : 0
/var/lib/mock/scl70fc23x/build.log:Tests failed : 0
/var/lib/mock/scl70fc24x/build.log:Tests failed : 0
-el6x, el7x, fc20x
+el6x, el7x
Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
+el7x:
+ * Bug #64438 proc_open hangs with stdin/out with 4097+ bytes [ext/standard/tests/streams/proc_open_bug64438.phpt]
* proc_open give erratic test results :(
diff --git a/php-5.5.30-curl.patch b/php-5.5.30-curl.patch
deleted file mode 100644
index 0c72d56..0000000
--- a/php-5.5.30-curl.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -up php-5.5.30/ext/curl/interface.c.old php-5.5.30/ext/curl/interface.c
---- php-5.5.30/ext/curl/interface.c.old 2015-12-14 13:58:27.911676702 +0100
-+++ php-5.5.30/ext/curl/interface.c 2015-12-14 14:08:04.581124497 +0100
-@@ -1213,7 +1213,9 @@ PHP_MINIT_FUNCTION(curl)
- REGISTER_CURL_CONSTANT(CURLSSLOPT_ALLOW_BEAST);
- #endif
-
--#if LIBCURL_VERSION_NUM >= 0x072200 /* Available since 7.34.0 */
-+#if LIBCURL_VERSION_NUM >= 0x071300 /* Available since 7.19.0 (in upstream curl 7.34)
-+ backported in RHEL-7 curl-7.29.0-16.el7 rhbz#1012136
-+ backported in RHEL-6 curl-7.19.7-43.el6 rhbz#1036789 */
- REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_0);
- REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_1);
- REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_2);
diff --git a/php-7.0.7-curl.patch b/php-7.0.7-curl.patch
new file mode 100644
index 0000000..218db98
--- /dev/null
+++ b/php-7.0.7-curl.patch
@@ -0,0 +1,15 @@
+diff -up php-7.0.7RC1/ext/curl/interface.c.curltls php-7.0.7RC1/ext/curl/interface.c
+--- php-7.0.7RC1/ext/curl/interface.c.curltls 2016-05-10 17:28:33.000000000 +0200
++++ php-7.0.7RC1/ext/curl/interface.c 2016-05-12 07:43:00.900419946 +0200
+@@ -1257,7 +1257,11 @@ PHP_MINIT_FUNCTION(curl)
+
+ #if LIBCURL_VERSION_NUM >= 0x072200 /* Available since 7.34.0 */
+ REGISTER_CURL_CONSTANT(CURLOPT_LOGIN_OPTIONS);
++#endif
+
++#if LIBCURL_VERSION_NUM >= 0x071300 /* Available since 7.19.0 (in upstream curl 7.34)
++ backported in RHEL-7 curl-7.29.0-16.el7 rhbz#1012136
++ backported in RHEL-6 curl-7.19.7-43.el6 rhbz#1036789 */
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_0);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_1);
+ REGISTER_CURL_CONSTANT(CURL_SSLVERSION_TLSv1_2);
diff --git a/php.spec b/php.spec
index 0f625e7..f23362b 100644
--- a/php.spec
+++ b/php.spec
@@ -27,7 +27,7 @@
%global pdover 20150127
# Extension version
%global opcachever 7.0.6-dev
-%global oci8ver 2.1.0
+%global oci8ver 2.1.1
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -125,13 +125,13 @@
%global db_devel libdb-devel
%endif
-#global rcver RC1
-%global rpmrel 3
+%global rcver RC1
+%global rpmrel 1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: 7.0.6
+Version: 7.0.7
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -166,7 +166,7 @@ Patch5: php-7.0.0-includedir.patch
Patch6: php-5.6.3-embed.patch
Patch7: php-5.3.0-recode.patch
Patch8: php-7.0.2-libdb.patch
-Patch9: php-5.5.30-curl.patch
+Patch9: php-7.0.7-curl.patch
# Functional changes
Patch40: php-7.0.0-dlopen.patch
@@ -1827,6 +1827,10 @@ fi
%changelog
+* Thu May 12 2016 Remi Collet <remi@fedoraproject.org> 7.0.7-0.1.RC1
+- Update to 7.0.7RC1
+- oci8 version is now 2.1.1
+
* Thu Apr 28 2016 Remi Collet <remi@fedoraproject.org> 7.0.6-3
- Update to 7.0.6 - http://www.php.net/releases/7_0_6.php
- rebuild for new sources