summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--10-opcache.ini2
-rw-r--r--failed.txt11
-rw-r--r--php-7.0.0-systzdata-v13.patch (renamed from php-7.0.0-systzdata-v12.patch)11
-rw-r--r--php.conf23
-rw-r--r--php.spec10
5 files changed, 24 insertions, 13 deletions
diff --git a/10-opcache.ini b/10-opcache.ini
index 7477caa..cfbff55 100644
--- a/10-opcache.ini
+++ b/10-opcache.ini
@@ -108,4 +108,4 @@ opcache.blacklist_filename=/etc/php.d/opcache*.blacklist
; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
; This should improve performance, but requires appropriate OS configuration.
-;opcache.huge_code_pages=1
+;opcache.huge_code_pages=0
diff --git a/failed.txt b/failed.txt
index 65ba366..39cebe0 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,13 +1,16 @@
-===== 7.0.0-0.16.RC3 (2015-09-17)
+===== 7.0.0-0.18.RC4 (2015-10-01)
$ grep -r 'Tests failed' /var/lib/mock/scl70*/build.log
-/var/lib/mock/scl70el6x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/scl70el7x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
-/var/lib/mock/scl70fc20x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70el6x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70el7x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
+/var/lib/mock/scl70fc20x/build.log:Tests failed : 2 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc21x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%
/var/lib/mock/scl70fc22x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
/var/lib/mock/scl70fc23x/build.log:Tests failed : 0 ( 0.0%) ( 0.0%)
+el6x, el7x, fc20x
+ Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt]
+ strtotime() function (64 bit) [ext/date/tests/strtotime3-64bit.phpt]
* proc_open give erratic test results :(
diff --git a/php-7.0.0-systzdata-v12.patch b/php-7.0.0-systzdata-v13.patch
index 560faef..5efc47d 100644
--- a/php-7.0.0-systzdata-v12.patch
+++ b/php-7.0.0-systzdata-v13.patch
@@ -2,6 +2,7 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
+r13: adapt for upstream changes to use PHP allocator
r12: adapt for upstream changes for new zic
r11: use canonical names to avoid more case sensitivity issues
round lat/long from zone.tab towards zero per builtin db
@@ -435,9 +436,9 @@ diff -up php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata php-7.0.0RC1/ext/date/li
+{
+ if (timezonedb_system) {
+ timelib_tzdb_index_entry *ent, lookup;
-+
++
+ lookup.id = (char *)timezone;
-+
++
+ ent = bsearch(&lookup, timezonedb_system->index,
+ timezonedb_system->index_size, sizeof lookup,
+ sysdbcmp);
@@ -609,8 +610,8 @@ diff -up php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata php-7.0.0RC1/ext/date/li
+ * if possible. */
+
+ if ((li = find_zone_info(system_location_table, timezone)) != NULL) {
-+ tmp->location.comments = strdup(li->comment);
-+ strncpy(tmp->location.country_code, li->code, 2);
++ tmp->location.comments = timelib_strdup(li->comment);
++ strncpy(tmp->location.country_code, li->code, 2);
+ tmp->location.longitude = li->longitude;
+ tmp->location.latitude = li->latitude;
+ tmp->bc = 1;
@@ -618,7 +619,7 @@ diff -up php-7.0.0RC1/ext/date/lib/parse_tz.c.systzdata php-7.0.0RC1/ext/date/li
+ else {
+ strcpy(tmp->location.country_code, "??");
+ tmp->bc = 0;
-+ tmp->location.comments = strdup("");
++ tmp->location.comments = timelib_strdup("");
+ }
+
+ /* Now done with the mmap segment - discard it. */
diff --git a/php.conf2 b/php.conf2
index 2c12ca8..fc6de6f 100644
--- a/php.conf2
+++ b/php.conf2
@@ -2,6 +2,9 @@
# Redirect to local php-fpm if mod_php (5 or 7) is not available
<IfModule !mod_php5.c>
<IfModule !mod_php7.c>
+ # Enable http authorization headers
+ SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
+
<FilesMatch \.php$>
SetHandler "proxy:fcgi://127.0.0.1:9000"
</FilesMatch>
diff --git a/php.spec b/php.spec
index 7c1ba0e..f8b37f1 100644
--- a/php.spec
+++ b/php.spec
@@ -130,8 +130,8 @@
#global gh_date 20150623
#global gh_owner php
#global gh_project php-src
-%global rcver RC3
-%global rpmrel 17
+%global rcver RC4
+%global rpmrel 18
Summary: PHP scripting language for creating dynamic web sites
@@ -182,7 +182,7 @@ Patch21: php-7.0.0-odbctimer.patch
# Functional changes
Patch40: php-7.0.0-dlopen.patch
-Patch42: php-7.0.0-systzdata-v12.patch
+Patch42: php-7.0.0-systzdata-v13.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -1803,6 +1803,10 @@ fi
%changelog
+* Wed Sep 30 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.18.RC4
+- Update to 7.0.0RC4
+- php-fpm: set http authorization headers
+
* Fri Sep 18 2015 Remi Collet <remi@fedoraproject.org> 7.0.0-0.17.RC3
- F23 rebuild with rh_layout