summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-01-18 14:52:20 +0100
committerRemi Collet <remi@remirepo.net>2019-01-18 14:52:20 +0100
commit5cfa3a140e0b15489056eb2ccb108f81c89631aa (patch)
tree775194f8f72d42b8f31700a1f2922592c1d747ef /php.spec
parenta541ab98e1c371d19abfa52e115b0b68fe67e6a7 (diff)
cleanup for EL-8
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec47
1 files changed, 36 insertions, 11 deletions
diff --git a/php.spec b/php.spec
index aa82877..79092c5 100644
--- a/php.spec
+++ b/php.spec
@@ -71,7 +71,12 @@
# Optional components; pass "--with mssql" etc to rpmbuild.
%global with_oci8 %{?_with_oci8:1}%{!?_with_oci8:0}
%global with_imap 1
+# until firebird available in EPEL
+%if 0%{?rhel} == 8
+%global with_interbase 0
+%else
%global with_interbase 1
+%endif
%global with_mcrypt 1
%global with_freetds 1
%global with_tidy 1
@@ -104,7 +109,7 @@
%global with_systemd 0
%endif
# httpd 2.4.10 with httpd-filesystem and sethandler support
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
%global with_httpd2410 1
%else
%global with_httpd2410 0
@@ -126,7 +131,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -251,7 +256,7 @@ Requires(pre): httpd-filesystem
%else
Requires(pre): httpd
%endif
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# httpd have threaded MPM by default
Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
%endif
@@ -908,7 +913,7 @@ support for JavaScript Object Notation (JSON) to PHP.
%if 0%{?rhel}
%patch9 -p1 -b .curltls
%endif
-%if 0%{?fedora} >= 29
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
%patch10 -p1 -b .icu62
%endif
@@ -1053,7 +1058,7 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
-e "s:@BINDIR@:%{_bindir}:" \
-e "s:@SCL@:%{?scl:%{scl}_}:" \
%{SOURCE3} | tee macros.php
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
echo '%%%{?scl:%{scl}_}pecl_xmldir %{_localstatedir}/lib/php/peclxml' | tee -a macros.php
%endif
@@ -1404,7 +1409,7 @@ install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/session
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/wsdlcache
install -m 700 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/opcache
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
install -m 755 -d $RPM_BUILD_ROOT%{_localstatedir}/lib/php/peclxml
install -m 755 -d $RPM_BUILD_ROOT%{_docdir}/pecl
install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/tests/pecl
@@ -1437,7 +1442,7 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf.default .
# install systemd unit files and scripts for handling server startup
%if %{with_systemd}
install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
%endif
@@ -1480,7 +1485,7 @@ sed -e 's:/run:%{_localstatedir}/run:' \
-i $RPM_BUILD_ROOT%{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
# Environment file
-%if 0%{?fedora} >= 26
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
%else
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
@@ -1697,6 +1702,23 @@ fi
%endif
+%posttrans common
+cat << EOF
+=====================================================================
+
+ WARNING : PHP 7.0 have reached its "End of Life" in December 2018.
+ Even, if this package includes some of the important security fix,
+ backported from 7.1,
+ The UPGRADE to a maintained version is very strongly RECOMMENDED.
+
+%if %{?fedora}%{!?fedora:99} < 28
+ WARNING : Fedora %{fedora} is now EOL :
+ You should consider upgrading to a supported release
+%endif
+=====================================================================
+EOF
+
+
%{!?_licensedir:%global license %%doc}
%files
@@ -1728,7 +1750,7 @@ fi
%dir %{_libdir}/php/modules
%dir %{_localstatedir}/lib/php
%dir %{_datadir}/php
-%if 0%{?fedora} >= 24
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 8
%dir %{_localstatedir}/lib/php/peclxml
%dir %{_docdir}/pecl
%dir %{_datadir}/tests
@@ -1774,13 +1796,13 @@ fi
%config(noreplace) %{_sysconfdir}/php-fpm.conf
%config(noreplace) %{_sysconfdir}/php-fpm.d/www.conf
%config(noreplace) %{_root_sysconfdir}/logrotate.d/%{?scl_prefix}php-fpm
-%if 0%{?fedora} < 26
+%if 0%{?fedora} < 26 && 0%{?rhel} < 8
%config(noreplace) %{_sysconfdir}/sysconfig/php-fpm
%endif
# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
%endif
@@ -1874,6 +1896,9 @@ fi
%changelog
+* Fri Jan 18 2019 Remi Collet <remi@remirepo.net> - 7.0.33-3
+- cleanup for EL-8
+
* Wed Jan 9 2019 Remi Collet <remi@remirepo.net> - 7.0.33-2
- core:
Fix #77369 memcpy with negative length via crafted DNS response