summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-25 15:17:39 +0200
committerRemi Collet <remi@remirepo.net>2017-09-25 15:17:39 +0200
commit83353a48a8f5935f8c9eb1a21e9ddbb6deb0c08e (patch)
tree21b43c0d9d43f7e74199bcaf3982e0a7fd8fd68d /php.spec
parentb1c22054d13ed677c0a4baecf087bb3c824b3ec0 (diff)
F27: php now requires php-fpm and start it with httpd / nginx
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec23
1 files changed, 19 insertions, 4 deletions
diff --git a/php.spec b/php.spec
index 1268409..4f9b187 100644
--- a/php.spec
+++ b/php.spec
@@ -129,7 +129,7 @@
%endif
#global rcver RC1
-%global rpmrel 3
+%global rpmrel 4
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -160,7 +160,8 @@ Source8: php-fpm.sysconfig
Source9: php.modconf
Source10: php.conf2
Source11: php-fpm.init
-Source12: strip.sh
+Source12: php-fpm.wants
+Source13: strip.sh
# Configuration files for some extensions
Source50: opcache.ini
Source51: opcache-default.blacklist
@@ -239,6 +240,10 @@ Requires(pre): httpd-filesystem
%else
Requires(pre): httpd
%endif
+%if 0%{?fedora} >= 27
+# httpd have threaded MPM by default
+Requires: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+%endif
# Don't provides extensions, or shared libraries (embedded)
@@ -1371,8 +1376,11 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.conf.default .
# install -m 644 php-fpm.tmpfiles $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/php-fpm.conf
# install systemd unit files and scripts for handling server startup
%if %{with_systemd}
-install -m 755 -d $RPM_BUILD_ROOT%{_unitdir}
-install -m 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
+install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
+%if 0%{?fedora} >= 27
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
+%endif
sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/etc/sysconfig:%{_sysconfdir}/sysconfig:' \
-e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
@@ -1720,6 +1728,10 @@ fi
# {_prefix}/lib/tmpfiles.d/php-fpm.conf
%if %{with_systemd}
%{_unitdir}/%{?scl_prefix}php-fpm.service
+%if 0%{?fedora} >= 27
+%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
+%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
+%endif
%dir %{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
%else
%{_root_initddir}/%{?scl_prefix}php-fpm
@@ -1806,6 +1818,9 @@ fi
%changelog
+* Mon Sep 25 2017 Remi Collet <remi@fedoraproject.org> - 5.6.31-4
+- F27: php now requires php-fpm and start it with httpd / nginx
+
* Fri Aug 25 2017 Remi Collet <remi@fedoraproject.org> - 5.6.31-3
- disable httpd MPM check