summaryrefslogtreecommitdiffstats
path: root/roundcubemail.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-22 11:12:07 +0200
committerRemi Collet <remi@remirepo.net>2021-04-22 11:12:07 +0200
commit9a30a40d95e033dd03cde6438807c1da5674583e (patch)
tree1b305d36972565ddb44b9825320283dfed73d376 /roundcubemail.spec
parente212e3ce003cd02c827bb0b6d77e767b1afc7d4b (diff)
update to 1.5-beta
drop dependency on pear/net_idna2 raise dependency on pear/net_smtp 1.9 raise dependency on masterminds/html5 2.7 add dependency on guzzlehttp/guzzle switc from mkopinsky/zxcvbn-php to bjeavons/zxcvbn-php
Diffstat (limited to 'roundcubemail.spec')
-rw-r--r--roundcubemail.spec75
1 files changed, 43 insertions, 32 deletions
diff --git a/roundcubemail.spec b/roundcubemail.spec
index 395646a..5ac3bd6 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -17,8 +17,8 @@
%else
%global with_phpfpm 0
%endif
-%global upstream_version 1.4.10
-#global upstream_prever rc2
+%global upstream_version 1.5
+%global upstream_prever beta
%global roundcubedir %{_datadir}/roundcubemail
%global _logdir /var/log
@@ -48,7 +48,7 @@ Source2: roundcubemail.logrotate
Source4: roundcubemail-README-rpm.txt
# Non-upstreamable: Adjusts config path to Fedora policy
-Patch1: roundcubemail-1.4-confpath.patch
+Patch1: roundcubemail-1.5-confpath.patch
BuildArch: noarch
@@ -56,9 +56,8 @@ BuildArch: noarch
BuildRequires: php-cli
BuildRequires: php-pear(PEAR) >= 1.10.1
BuildRequires: php-pear(Auth_SASL) >= 1.1.0
-BuildRequires: php-pear(Net_IDNA2) >= 0.2.0
BuildRequires: php-pear(Mail_Mime) >= 1.10.0
-BuildRequires: php-pear(Net_SMTP) >= 1.8.1
+BuildRequires: php-pear(Net_SMTP) >= 1.9.0
BuildRequires: php-pear(Crypt_GPG) >= 1.6.0
BuildRequires: php-pear(Net_Sieve) >= 1.4.3
BuildRequires: php-pear(Net_LDAP2) >= 2.2.0
@@ -67,13 +66,16 @@ BuildRequires: php-composer(fedora/autoloader)
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(endroid/qrcode) >= 1.6.5 with php-composer(endroid/qrcode) < 2)
-BuildRequires: (php-composer(masterminds/html5) >= 2.5.0 with php-composer(masterminds/html5) < 3)
-# remirepo:6
+BuildRequires: (php-composer(masterminds/html5) >= 2.7.0 with php-composer(masterminds/html5) < 3)
+BuildRequires: (php-composer(guzzlehttp/guzzle) >= 6.5.5 with php-composer(guzzlehttp/guzzle) < 7)
+# remirepo:8
%else
-BuildRequires: php-composer(endroid/qrcode) < 2
-BuildRequires: php-composer(endroid/qrcode) >= 1.6.5
-BuildRequires: php-composer(masterminds/html5) < 3
-BuildRequires: php-composer(masterminds/html5) >= 2.5.0
+BuildRequires: php-endroid-qrcode < 2
+BuildRequires: php-endroid-qrcode >= 1.6.5
+BuildRequires: php-masterminds-html5 < 3
+BuildRequires: php-masterminds-html5 >= 2.7.0
+BuildRequires: php-guzzlehttp-guzzle6 < 7
+BuildRequires: php-guzzlehttp-guzzle6 >= 6.5.5
%endif
%if %{with_phpfpm}
@@ -107,24 +109,23 @@ Requires: php-sockets
Requires: php-spl
Requires: php-xml
# From composer.json-dist, require
-# "php": ">=5.4.0",
+# "php": ">=5.5.0",
# "pear/pear-core-minimal": "~1.10.1",
# "pear/auth_sasl": "~1.1.0",
-# "pear/net_idna2": "~0.2.0",
# "pear/mail_mime": "~1.10.0",
-# "pear/net_smtp": "~1.8.1",
+# "pear/net_smtp": "~1.9.0",
# "pear/crypt_gpg": "~1.6.0",
# "pear/net_sieve": "~1.4.3",
# "roundcube/plugin-installer": "~0.1.6",
-# "masterminds/html5": "~2.5.0",
+# "masterminds/html5": "~2.7.0",
# "endroid/qrcode": "~1.6.5"
+# "guzzlehttp/guzzle": "^6.5.5",
# "kolab/net_ldap3": "~1.1.1"
# not available and doesn't make sense roundcube/plugin-installer
Requires: php-pear(PEAR) >= 1.10.1
Requires: php-pear(Auth_SASL) >= 1.1.0
-Requires: php-pear(Net_IDNA2) >= 0.2.0
Requires: php-pear(Mail_Mime) >= 1.10.0
-Requires: php-pear(Net_SMTP) >= 1.8.1
+Requires: php-pear(Net_SMTP) >= 1.9.0
Requires: php-pear(Crypt_GPG) >= 1.6.0
Requires: php-pear(Net_Sieve) >= 1.4.3
Requires: php-pear(Net_LDAP2) >= 2.2.0
@@ -132,16 +133,19 @@ Requires: php-composer(kolab/net_ldap3) >= 1.1.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(endroid/qrcode) >= 1.6.5 with php-composer(endroid/qrcode) < 2)
-Requires: (php-composer(masterminds/html5) >= 2.5.0 with php-composer(masterminds/html5) < 3)
+Requires: (php-composer(masterminds/html5) >= 2.7.0 with php-composer(masterminds/html5) < 3)
+Requires: (php-composer(guzzlehttp/guzzle) >= 6.5.5 with php-composer(guzzlehttp/guzzle) < 7)
# From composer.json-dist, "suggest": {
-# "mkopinsky/zxcvbn-php": "^4.4.2 required for Zxcvbn password strength driver"
-Suggests: (php-composer(mkopinsky/zxcvbn-php) >= 4.4.2 with php-composer(mkopinsky/zxcvbn-php) < 5)
-# remirepo:6
+# "bjeavons/zxcvbn-php": "^1.0 required for Zxcvbn password strength driver"
+Suggests: (php-composer(bjeavons/zxcvbn-php) >= 1.0 with php-composer(bjeavons/zxcvbn-php) < 5)
+# remirepo:8
%else
-Requires: php-composer(endroid/qrcode) < 2
-Requires: php-composer(endroid/qrcode) >= 1.6.5
-Requires: php-composer(masterminds/html5) < 3
-Requires: php-composer(masterminds/html5) >= 2.5.0
+Requires: php-endroid-qrcode < 2
+Requires: php-endroid-qrcode >= 1.6.5
+Requires: php-masterminds-html5 < 3
+Requires: php-masterminds-html5 >= 2.7.0
+Requires: php-guzzlehttp-guzzle6 < 7
+Requires: php-guzzlehttp-guzzle6 >= 6.5.5
%endif
# mailcap for /etc/mime.types
Requires: mailcap
@@ -200,7 +204,7 @@ CSS 2.
# fix permissions and remove any .htaccess files
find . -type f -print | xargs chmod a-x
-find . -name \.htaccess -print | xargs rm -f
+find . -name \.htaccess -delete -print
# drop file from patch
find . -type f -name '*.orig' -o -name '*.rpm' -exec rm {} \; -print
@@ -223,6 +227,7 @@ require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
# Composer components
\Fedora\Autoloader\Dependencies::required([
'%{_datadir}/php/Endroid/QrCode/autoload.php',
+ '%{_datadir}/php/GuzzleHttp6/autoload.php',
'%{_datadir}/php/Masterminds/HTML5/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
@@ -250,11 +255,6 @@ install -Dpm 0644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/nginx/default.d/%{name}
mkdir -p %{buildroot}%{_sysconfdir}/roundcubemail
install -pDm644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/roundcubemail
-%if 0%{?rhel} == 5 || 0%{?rhel} == 6
-: Remove "su" option from logrotate configuration file - requires logrotate 3.8+
-sed -e '/su /d' -i %{buildroot}%{_sysconfdir}/logrotate.d/roundcubemail
-%endif
-
# Log files
mkdir -p %{buildroot}/var/log/roundcubemail
# Temp files
@@ -295,7 +295,7 @@ rm %{buildroot}%{roundcubedir}/composer.json-dist
: Check our autoloader for needed classes
php -r '
require "%{buildroot}%{roundcubedir}/vendor/autoload.php";
-$cl = [ "Auth_SASL", "Crypt_GPG", "Mail_mime", "Net_IDNA2", "Net_LDAP2", "Masterminds\\HTML5",
+$cl = [ "Auth_SASL", "Crypt_GPG", "Mail_mime", "Net_LDAP2", "Masterminds\\HTML5", "GuzzleHttp\\Client",
"Net_LDAP3", "Net_Sieve", "Net_SMTP", "PEAR" , "Endroid\\QrCode\\QrCode" ];
$ret = 0;
foreach ($cl as $c) {
@@ -349,6 +349,17 @@ fi
%changelog
+* Thu Apr 22 2021 Remi Collet <remi@remirepo.net> - 1.5~beta-1
+- update to 1.5-beta
+- drop dependency on pear/net_idna2
+- raise dependency on pear/net_smtp 1.9
+- raise dependency on masterminds/html5 2.7
+- add dependency on guzzlehttp/guzzle
+- switc from mkopinsky/zxcvbn-php to bjeavons/zxcvbn-php
+
+* Tue Feb 9 2021 Remi Collet <remi@remirepo.net> - 1.4.11-1
+- update to 1.4.11
+
* Mon Dec 28 2020 Remi Collet <remi@remirepo.net> - 1.4.10-1
- update to 1.4.10