summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-21 10:53:21 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-21 10:53:21 +0200
commit9b93aaa32a636fdead984d5d97343ae4789a41e8 (patch)
treeff51f68f9550aa46607b3ba777f2b07a695250f0
parent6172bb5a3152f34718624e48b81710ef5aef7b3e (diff)
roundcubemail: 1.1.5
-rw-r--r--composer.json39
-rw-r--r--roundcubemail.spec13
2 files changed, 49 insertions, 3 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..e07e241
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,39 @@
+{
+ "name": "roundcube/roundcubemail",
+ "description": "The Roundcube Webmail suite",
+ "license": "GPL-3.0+",
+ "repositories": [
+ {
+ "type": "pear",
+ "url": "https://pear.php.net/"
+ },
+ {
+ "type": "composer",
+ "url": "https://plugins.roundcube.net/"
+ },
+ {
+ "type": "vcs",
+ "url": "https://git.kolab.org/diffusion/PNL/php-net_ldap.git"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.7",
+ "roundcube/plugin-installer": "~0.1.6",
+ "pear-pear.php.net/net_socket": "~1.0.12",
+ "pear-pear.php.net/auth_sasl": "~1.0.6",
+ "pear-pear.php.net/net_idna2": "~0.1.1",
+ "pear-pear.php.net/net_sieve": "~1.3.4",
+ "pear-pear.php.net/mail_mime": "~1.9.0",
+ "pear-pear.php.net/net_smtp": "~1.7.1",
+ "patchwork/utf8": "~1.2.3"
+ },
+ "require-dev": {
+ "pear-pear.php.net/crypt_gpg": "*",
+ "phpunit/phpunit": "*"
+ },
+ "suggest": {
+ "pear-pear.php.net/net_ldap2": "~2.1.0 required for connecting to LDAP address books",
+ "kolab/Net_LDAP3": "dev-master required for connecting to LDAP address books"
+ },
+ "minimum-stability": "dev"
+}
diff --git a/roundcubemail.spec b/roundcubemail.spec
index 2e4e6a4..838b25f 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -18,8 +18,8 @@
%global roundcubedir %{_datadir}/roundcubemail
%global _logdir /var/log
Name: roundcubemail
-Version: 1.1.4
-Release: 2%{?dist}
+Version: 1.1.5
+Release: 1%{?dist}
Summary: Round Cube Webmail is a browser-based multilingual IMAP client
Group: Applications/System
@@ -36,7 +36,7 @@ Group: Applications/System
# http://www.tinymce.com/
License: GPLv3+ with exceptions and GPLv3+ and GPLv2 and LGPLv2+ and CC-BY-SA and (MIT or GPLv2)
URL: http://www.roundcube.net
-Source0: https://downloads.sourceforge.net/roundcubemail/roundcubemail-%{version}.tar.gz
+Source0: https://github.com/roundcube/roundcubemail/releases/download/%{version}/roundcubemail-%{version}.tar.gz
Source1: roundcubemail.httpd
Source3: roundcubemail.nginx
Source2: roundcubemail.logrotate
@@ -87,6 +87,7 @@ Requires: php-xml
# From composer.json-dist, require
# "php": ">=5.3.7",
# "roundcube/plugin-installer": "~0.1.6",
+# "pear-pear.php.net/net_socket": "~1.0.12",
# "pear-pear.php.net/auth_sasl": "~1.0.6",
# "pear-pear.php.net/net_idna2": "~0.1.1",
# "pear-pear.php.net/net_sieve": "~1.3.4",
@@ -95,6 +96,7 @@ Requires: php-xml
# "patchwork/utf8": "~1.2.3"
# not available and optional patchwork/utf8
# not available and doesn't make sense roundcube/plugin-installer
+Requires: php-pear(Net_Socket) >= 1.0.12
Requires: php-pear(Auth_SASL) >= 1.0.6
Requires: php-pear(Mail_Mime) >= 1.9.0
Requires: php-pear(Net_SMTP) >= 1.7.1
@@ -275,6 +277,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 1.1.5-1
+- update to 1.1.5
+- sources from github
+- add dependency on Net_Socket >= 1.0.12
+
* Mon Dec 28 2015 Remi Collet <remi@fedoraproject.org> - 1.1.4-2
- add .log suffix to all log files, and rotate all #1269164
- more secure permissions on /var/log and /var/lib #1269155