summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-29 09:41:22 +0100
committerRemi Collet <fedora@famillecollet.com>2012-10-29 09:41:22 +0100
commit879f655185c6795f42638a52472a4e955a19d050 (patch)
tree229b43c71b2524794f2bf782008b0a3b0b61fb0d
parent1933ec592f4f82b0adf52c80cb722b8571c57896 (diff)
roundcubemail: add fix for latest MDB2 (#870933)
-rw-r--r--roundcubemail-0.8.2-mdb2.patch34
-rw-r--r--roundcubemail.spec10
2 files changed, 41 insertions, 3 deletions
diff --git a/roundcubemail-0.8.2-mdb2.patch b/roundcubemail-0.8.2-mdb2.patch
new file mode 100644
index 0000000..51f823c
--- /dev/null
+++ b/roundcubemail-0.8.2-mdb2.patch
@@ -0,0 +1,34 @@
+From 96f8436d77af05cf3c2d4f87970868221ddc6891 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Mon, 29 Oct 2012 09:22:33 +0100
+Subject: [PATCH] fix call to MDB2::isError for MDB2 2.5.0b4
+
+---
+ program/include/rcube_mdb2.php | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/program/include/rcube_mdb2.php b/program/include/rcube_mdb2.php
+index 3d8891d..876ee02 100644
+--- a/program/include/rcube_mdb2.php
++++ b/program/include/rcube_mdb2.php
+@@ -288,7 +288,7 @@ private function _query($query, $offset, $numrows, $params)
+ else {
+ $params = (array)$params;
+ $q = $this->db_handle->prepare($query, null, $mode=='w' ? MDB2_PREPARE_MANIP : null);
+- if ($this->db_handle->isError($q)) {
++ if (MDB2::isError($q)) {
+ $this->db_error = true;
+ $this->db_error_msg = $q->userinfo;
+
+@@ -369,7 +369,7 @@ function insert_id($table = '')
+
+ $id = $this->db_handle->lastInsertID($table);
+
+- return $this->db_handle->isError($id) ? null : $id;
++ return MDB2::isError($id) ? null : $id;
+ }
+
+
+--
+1.7.10
+
diff --git a/roundcubemail.spec b/roundcubemail.spec
index 675579c..e2eec9e 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -2,7 +2,7 @@
%global _logdir /var/log
Name: roundcubemail
Version: 0.8.2
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Round Cube Webmail is a browser-based multilingual IMAP client
Group: Applications/System
@@ -15,7 +15,8 @@ Source4: roundcubemail-README.fedora
# Non-upstremable: Adjusts config path to Fedora policy
Patch6: roundcubemail-0.4.1-confpath.patch
Patch7: roundcubemail-0.8.1-strict.patch
-#Patch8: roundcubemail-0.7.3-xss-sig.patch
+# https://bugzilla.redhat.com/870933
+Patch8: roundcubemail-0.8.2-mdb2.patch
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root%(%{__id_u} -n)
@@ -48,7 +49,7 @@ interface is fully skinnable using XHTML and CSS 2.
%patch6 -p0
%patch7 -p0
-#%patch8 -p0
+%patch8 -p1
# fix permissions and remove any .htaccess files
find . -type f -print | xargs chmod a-x
@@ -140,6 +141,9 @@ exit 0
%config(noreplace) %{_sysconfdir}/logrotate.d/roundcubemail
%changelog
+* Sun Oct 28 2012 Remi Collet <remi@fedoraproject.org> - 0.8.2-2
+- add fix for latest MDB2 (#870933)
+
* Wed Oct 10 2012 Jon Ciesla <limburgher@gmail.com> - 0.8.2-1
- Latest upstream.