summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-27 14:25:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-27 14:25:11 +0200
commit36bf01ca6ef5ea6eaae62d72da03c07126012f6b (patch)
treef92b7d06c631cb04519e11000564d789d4f45f51
parentc7a440985ff3359517c961951a14f3178121a8b6 (diff)
roundcubemail: 1.2.0
-rw-r--r--composer-dev.json42
-rw-r--r--composer.json13
-rw-r--r--roundcubemail.spec14
3 files changed, 17 insertions, 52 deletions
diff --git a/composer-dev.json b/composer-dev.json
deleted file mode 100644
index 58c50c7..0000000
--- a/composer-dev.json
+++ /dev/null
@@ -1,42 +0,0 @@
-{
- "name": "roundcube/roundcubemail",
- "description": "The Roundcube Webmail suite",
- "license": "GPL-3.0+",
- "repositories": [
- {
- "type": "pear",
- "url": "https://pear.php.net/"
- },
- {
- "type": "composer",
- "url": "https://plugins.roundcube.net/"
- },
- {
- "type": "vcs",
- "url": "https://github.com/roundcube/Net_Sieve.git"
- },
- {
- "type": "vcs",
- "url": "https://git.kolab.org/diffusion/PNL/php-net_ldap.git"
- }
- ],
- "require": {
- "php": ">=5.3.7",
- "roundcube/plugin-installer": "~0.1.6",
- "pear-pear.php.net/net_socket": "~1.0.12",
- "pear-pear.php.net/auth_sasl": "~1.0.6",
- "pear-pear.php.net/net_idna2": "~0.1.1",
- "pear-pear.php.net/mail_mime": "~1.10.0",
- "pear-pear.php.net/net_smtp": "~1.7.1",
- "pear-pear.php.net/crypt_gpg": "~1.4.0",
- "roundcube/net_sieve": "~1.5.0"
- },
- "require-dev": {
- "phpunit/phpunit": "*"
- },
- "suggest": {
- "pear-pear.php.net/net_ldap2": "~2.2.0 required for connecting to LDAP address books",
- "kolab/Net_LDAP3": "dev-master required for connecting to LDAP address books"
- },
- "minimum-stability": "dev"
-}
diff --git a/composer.json b/composer.json
index e07e241..f14541c 100644
--- a/composer.json
+++ b/composer.json
@@ -13,6 +13,10 @@
},
{
"type": "vcs",
+ "url": "https://github.com/roundcube/Net_Sieve.git"
+ },
+ {
+ "type": "vcs",
"url": "https://git.kolab.org/diffusion/PNL/php-net_ldap.git"
}
],
@@ -22,17 +26,16 @@
"pear-pear.php.net/net_socket": "~1.0.12",
"pear-pear.php.net/auth_sasl": "~1.0.6",
"pear-pear.php.net/net_idna2": "~0.1.1",
- "pear-pear.php.net/net_sieve": "~1.3.4",
- "pear-pear.php.net/mail_mime": "~1.9.0",
+ "pear-pear.php.net/mail_mime": "~1.10.0",
"pear-pear.php.net/net_smtp": "~1.7.1",
- "patchwork/utf8": "~1.2.3"
+ "pear-pear.php.net/crypt_gpg": "~1.4.1",
+ "roundcube/net_sieve": "~1.5.0"
},
"require-dev": {
- "pear-pear.php.net/crypt_gpg": "*",
"phpunit/phpunit": "*"
},
"suggest": {
- "pear-pear.php.net/net_ldap2": "~2.1.0 required for connecting to LDAP address books",
+ "pear-pear.php.net/net_ldap2": "~2.2.0 required for connecting to LDAP address books",
"kolab/Net_LDAP3": "dev-master required for connecting to LDAP address books"
},
"minimum-stability": "dev"
diff --git a/roundcubemail.spec b/roundcubemail.spec
index 5142ac1..3b6c3d6 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -14,13 +14,13 @@
%else
%global with_phpfpm 0
%endif
-%global prever rc
+#global prever rc
%global roundcubedir %{_datadir}/roundcubemail
%global _logdir /var/log
Name: roundcubemail
-Version: 1.2
-Release: 0.2.%{prever}%{?dist}
+Version: 1.2.0
+Release: 1%{?dist}
Summary: Round Cube Webmail is a browser-based multilingual IMAP client
Group: Applications/System
@@ -94,7 +94,7 @@ Requires: php-xml
# "pear-pear.php.net/net_idna2": "~0.1.1",
# "pear-pear.php.net/mail_mime": "~1.10.0",
# "pear-pear.php.net/net_smtp": "~1.7.1",
-# "pear-pear.php.net/crypt_gpg": "~1.4.0",
+# "pear-pear.php.net/crypt_gpg": "~1.4.1",
# "roundcube/net_sieve": "~1.5.0"
# not available and doesn't make sense roundcube/plugin-installer
Requires: php-pear(Net_Socket) >= 1.0.12
@@ -102,7 +102,7 @@ Requires: php-pear(Auth_SASL) >= 1.0.6
Requires: php-pear(Net_IDNA2) >= 0.1.1
Requires: php-pear(Mail_Mime) >= 1.10.0
Requires: php-pear(Net_SMTP) >= 1.7.1
-Requires: php-pear(Crypt_GPG) >= 1.4.0
+Requires: php-pear(Crypt_GPG) >= 1.4.1
Requires: php-composer(roundcube/net_sieve) >= 1.5.0
# From composer.json-dist, suggest
# "pear-pear.php.net/net_ldap2": "~2.2.0 required for connecting to LDAP address books",
@@ -277,6 +277,10 @@ rm -rf %{buildroot}
%changelog
+* Fri May 27 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-1
+- update to 1.2.0
+- raise dependency on Crypt_GPG ~1.4.1
+
* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 1.2-0.2.rc
- update to 1.2-rc
- sources from github