summaryrefslogtreecommitdiffstats
path: root/redis.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redis.spec')
-rw-r--r--redis.spec22
1 files changed, 10 insertions, 12 deletions
diff --git a/redis.spec b/redis.spec
index 9e22162..35bc6d1 100644
--- a/redis.spec
+++ b/redis.spec
@@ -25,7 +25,7 @@
%bcond_with tests
# Pre-version are only available in github
-%global upstream_ver 7.0.10
+%global upstream_ver 7.0.11
#global upstream_pre RC3
%global gh_commit 5921ba4cdef2761bfed34b982368f1fe077d03e9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -35,7 +35,7 @@
# Commit IDs for the (unversioned) redis-doc repository
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
# https://github.com/redis/redis-doc/commits/master
-%global doc_commit 1a2f1b653f4b0b421eb1b00085b6ebec810f2e48
+%global doc_commit c7880ba85fd67cb09110a4be790da47d4a6cec80
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
# %%{_rpmmacrodir} not usable on EL-6 - EL-7 (without epel-rpms-macros)
@@ -45,7 +45,6 @@ Name: redis
Version: %{upstream_ver}%{?upstream_pre:~%{upstream_pre}}
Release: 1%{?dist}
Summary: A persistent key-value database
-Group: Applications/Databases
# redis, hiredis: BSD-3-Clause
# hdrhistogram, jemalloc, lzf, linenoise: BSD-2-Clause
# lua: MIT
@@ -59,7 +58,6 @@ Source0: https://download.redis.io/releases/%{name}-%{version}.tar.gz
Source1: %{name}.logrotate
Source2: %{name}-sentinel.service
Source3: %{name}.service
-Source6: %{name}-shutdown
Source7: %{name}-limit-systemd
Source9: macros.%{name}
Source10: https://github.com/%{gh_owner}/%{gh_project}-doc/archive/%{doc_commit}/%{name}-doc-%{short_doc_commit}.tar.gz
@@ -97,8 +95,6 @@ BuildRequires: openssl-devel >= 1.0.2
Obsoletes: redis-trib < %{version}-%{release}
%endif
-# Required for redis-shutdown
-Requires: /bin/awk
Requires: logrotate
Requires(pre): shadow-utils
Requires(post): systemd
@@ -261,9 +257,6 @@ install -p -D -m 644 %{S:7} %{buildroot}%{_sysconfdir}/systemd/system/%{name}-se
# Fix non-standard-executable-perm error.
chmod 755 %{buildroot}%{_bindir}/%{name}-*
-# Install redis-shutdown
-install -pDm755 %{S:6} %{buildroot}%{_libexecdir}/%{name}-shutdown
-
# Install redis module header
install -pDm644 src/%{name}module.h %{buildroot}%{_includedir}/%{name}module.h
@@ -374,8 +367,8 @@ fi
%attr(0750, redis, root) %dir %{_sysconfdir}/%{name}
%attr(0640, redis, root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
%attr(0640, redis, root) %config(noreplace) %{_sysconfdir}/%{name}/sentinel.conf
-%dir %attr(0750, redis, redis) %{_libdir}/%{name}
-%dir %attr(0750, redis, redis) %{redis_modules_dir}
+%dir %{_libdir}/%{name}
+%dir %{redis_modules_dir}
%dir %attr(0750, redis, redis) %{_sharedstatedir}/%{name}
%dir %attr(0750, redis, redis) %{_localstatedir}/log/%{name}
%if %{with redistrib}
@@ -385,7 +378,6 @@ fi
%exclude %{_includedir}
%exclude %{_docdir}/%{name}/*
%{_bindir}/%{name}-*
-%{_libexecdir}/%{name}-*
%{_mandir}/man1/%{name}*
%{_mandir}/man5/%{name}*
%{_unitdir}/%{name}.service
@@ -414,6 +406,12 @@ fi
%changelog
+* Tue Apr 18 2023 Remi Collet <remi@remirepo.net> - 7.0.11-1
+- Redis 7.0.11 Released Mon Apr 17 16:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+- fix modules directory ownership and permissions #2176173
+- drop redis-shutdown helper and rely on systemd #2181181
+
* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 7.0.10-1
- Redis 7.0.10 Released Mon Mar 20 16:00:00 IST 2023
- Upgrade urgency: SECURITY, contains fixes to security issues.