summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--redis.spec60
1 files changed, 44 insertions, 16 deletions
diff --git a/redis.spec b/redis.spec
index 847bdfb..a8dea1b 100644
--- a/redis.spec
+++ b/redis.spec
@@ -25,24 +25,21 @@
%bcond_with tests
# Pre-version are only available in github
-%global upstream_ver 6.2.10
-#global upstream_pre RC3
-%global gh_commit 2dba1e391d3772a8da182d95bde050ffa9d01e4d
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global upstream_ver 6.2.18
%global gh_owner redis
%global gh_project redis
# Commit IDs for the (unversioned) redis-doc repository
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
# https://github.com/redis/redis-doc/commits/master
-%global doc_commit 281af38767956c125d237ff4015485516bcfaf23
+%global doc_commit 3541d0e20cc4bb7873bdbf51a7717757b806577f
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
# %%{_rpmmacrodir} not usable on EL-6 - EL-7 (without epel-rpms-macros)
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
Name: redis
-Version: %{upstream_ver}%{?upstream_pre:~%{upstream_pre}}
+Version: %{upstream_ver}
Release: 1%{?dist}
Summary: A persistent key-value database
Group: Applications/Databases
@@ -51,11 +48,8 @@ Group: Applications/Databases
# lua: MIT
License: BSD-3-Clause AND BSD-2-Clause AND MIT
URL: http://redis.io
-%if 0%{?upstream_pre:1}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{upstream_ver}%{upstream_pre}-%{gh_short}.tar.gz
-%else
-Source0: https://download.redis.io/releases/%{name}-%{version}.tar.gz
-%endif
+#ource0: https://download.redis.io/releases/%%{name}-%%{version}.tar.gz
+Source0: https://github.com/redis/redis/archive/refs/tags/%{version}.tar.gz
Source1: %{name}.logrotate
Source2: %{name}-sentinel.service
Source3: %{name}.service
@@ -175,13 +169,9 @@ and removal, status checks, resharding, rebalancing, and other operations.
%endif
%prep
-%if 0%{?upstream_pre:1}
-%setup -q -n %{gh_project}-%{gh_commit} -b 10
-%else
%setup -q -b 10
-%endif
mv ../%{name}-doc-%{doc_commit} doc
-%patch0001 -p1
+%patch -P0001 -p1
%if %{with jemalloc}
rm -frv deps/jemalloc
@@ -200,6 +190,15 @@ sed -i -e 's|^logfile .*$|logfile /var/log/redis/redis.log|g' redis.conf
sed -i -e 's|^logfile .*$|logfile /var/log/redis/sentinel.log|g' sentinel.conf
sed -i -e 's|^dir .*$|dir /var/lib/redis|g' redis.conf
+# See https://bugzilla.redhat.com/2240293
+# See https://src.fedoraproject.org/rpms/jemalloc/blob/rawhide/f/jemalloc.spec#_34
+%ifarch %ix86 %arm x86_64 s390x
+sed -e 's/--with-lg-quantum/--with-lg-page=12 --with-lg-quantum/' -i deps/Makefile
+%endif
+%ifarch ppc64 ppc64le aarch64
+sed -e 's/--with-lg-quantum/--with-lg-page=16 --with-lg-quantum/' -i deps/Makefile
+%endif
+
# Module API version safety check
api=`sed -n -e 's/#define REDISMODULE_APIVER_[0-9][0-9]* //p' src/redismodule.h`
if test "$api" != "%{redis_modules_abi}"; then
@@ -408,6 +407,35 @@ fi
%changelog
+* Thu Apr 24 2025 Remi Collet <remi@remirepo.net> - 6.2.18-1
+- Redis 6.2.18 Released Wed 23 Apr 2025 12:00:00 IST
+- Update urgency: `SECURITY`: CVE-2025-21605
+
+* Mon Jan 6 2025 Remi Collet <remi@remirepo.net> - 6.2.17-1
+- Redis 6.2.17 Released Mon 6 Jan 2025 12:30:00 IDT
+- Upgrade urgency SECURITY: CVE-2024-46981
+
+* Thu Oct 3 2024 Remi Collet <remi@remirepo.net> - 6.2.16-1
+- Redis Community Edition 6.2.16 Released Wed 02 Oct 2024 20:17:04 IDT
+- Upgrade urgency SECURITY: CVE-2024-31449 and CVE-2024-31228
+
+-* Wed Oct 18 2023 Remi Collet <remi@remirepo.net> - 6.2.14-1
+- Redis 6.2.14 Released Wed 18 Oct 2023 10:33:40 IDT
+- Upgrade urgency SECURITY: CVE-2023-45145
+- set jemalloc page size #2240293
+
+* Mon Jul 10 2023 Remi Collet <remi@remirepo.net> - 6.2.13-1
+- Redis 6.2.13 Released Mon July 10 12:00:00 IDT 2023
+- Upgrade urgency SECURITY
+
+* Tue Apr 18 2023 Remi Collet <remi@remirepo.net> - 6.2.12-1
+- Redis 6.2.12 Released Mon Apr 17 16:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 6.2.11-1
+- Redis 6.2.11 Released Tue Feb 28 12:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues
+
* Wed Jan 18 2023 Remi Collet <remi@remirepo.net> - 6.2.10-1
- Redis 6.2.10 Released Mon Jan 17 12:00:00 IST 2023
- Upgrade urgency: MODERATE, a quick followup fix for a recently released 6.2.9.