summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--redis.spec58
1 files changed, 52 insertions, 6 deletions
diff --git a/redis.spec b/redis.spec
index be2f255..d875a2f 100644
--- a/redis.spec
+++ b/redis.spec
@@ -25,7 +25,7 @@
%bcond_with tests
# Pre-version are only available in github
-%global upstream_ver 6.2.6
+%global upstream_ver 6.2.14
#global upstream_pre RC3
%global gh_commit 2dba1e391d3772a8da182d95bde050ffa9d01e4d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
@@ -35,7 +35,7 @@
# Commit IDs for the (unversioned) redis-doc repository
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
# https://github.com/redis/redis-doc/commits/master
-%global doc_commit 3fdb6df44ecd5c4d99ea52a0133177f5ebc24805
+%global doc_commit 4d345ac90a0c8dbf759238478b38829e2c5e807e
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
# %%{_rpmmacrodir} not usable on EL-6 - EL-7 (without epel-rpms-macros)
@@ -43,10 +43,13 @@
Name: redis
Version: %{upstream_ver}%{?upstream_pre:~%{upstream_pre}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: A persistent key-value database
Group: Applications/Databases
-License: BSD
+# redis, hiredis: BSD-3-Clause
+# jemalloc, lzf, linenoise: BSD-2-Clause
+# lua: MIT
+License: BSD-3-Clause AND BSD-2-Clause AND MIT
URL: http://redis.io
%if 0%{?upstream_pre:1}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{upstream_ver}%{upstream_pre}-%{gh_short}.tar.gz
@@ -149,7 +152,7 @@ API documentation is available in the redis-doc package.
%package doc
Summary: Documentation for Redis including man pages
-License: CC-BY-SA
+License: CC-BY-SA-4.0
BuildArch: noarch
# http://fedoraproject.org/wiki/Packaging:Conflicts "Splitting Packages"
@@ -178,7 +181,7 @@ and removal, status checks, resharding, rebalancing, and other operations.
%setup -q -b 10
%endif
mv ../%{name}-doc-%{doc_commit} doc
-%patch0001 -p1
+%patch -P0001 -p1
%if %{with jemalloc}
rm -frv deps/jemalloc
@@ -197,6 +200,15 @@ sed -i -e 's|^logfile .*$|logfile /var/log/redis/redis.log|g' redis.conf
sed -i -e 's|^logfile .*$|logfile /var/log/redis/sentinel.log|g' sentinel.conf
sed -i -e 's|^dir .*$|dir /var/lib/redis|g' redis.conf
+# See https://bugzilla.redhat.com/2240293
+# See https://src.fedoraproject.org/rpms/jemalloc/blob/rawhide/f/jemalloc.spec#_34
+%ifarch %ix86 %arm x86_64 s390x
+sed -e 's/--with-lg-quantum/--with-lg-page=12 --with-lg-quantum/' -i deps/Makefile
+%endif
+%ifarch ppc64 ppc64le aarch64
+sed -e 's/--with-lg-quantum/--with-lg-page=16 --with-lg-quantum/' -i deps/Makefile
+%endif
+
# Module API version safety check
api=`sed -n -e 's/#define REDISMODULE_APIVER_[0-9][0-9]* //p' src/redismodule.h`
if test "$api" != "%{redis_modules_abi}"; then
@@ -405,6 +417,40 @@ fi
%changelog
+* Wed Oct 18 2023 Remi Collet <remi@remirepo.net> - 6.2.14-1
+- Redis 6.2.14 Released Wed 18 Oct 2023 10:33:40 IDT
+- Upgrade urgency SECURITY: CVE-2023-45145
+- set jemalloc page size #2240293
+
+* Mon Jul 10 2023 Remi Collet <remi@remirepo.net> - 6.2.13-1
+- Redis 6.2.13 Released Mon July 10 12:00:00 IDT 2023
+- Upgrade urgency SECURITY
+
+* Tue Apr 18 2023 Remi Collet <remi@remirepo.net> - 6.2.12-1
+- Redis 6.2.12 Released Mon Apr 17 16:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 6.2.11-1
+- Redis 6.2.11 Released Tue Feb 28 12:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues
+
+* Wed Jan 18 2023 Remi Collet <remi@remirepo.net> - 6.2.10-1
+- Redis 6.2.10 Released Mon Jan 17 12:00:00 IST 2023
+- Upgrade urgency: MODERATE, a quick followup fix for a recently released 6.2.9.
+
+* Tue Jan 17 2023 Remi Collet <remi@remirepo.net> - 6.2.9-1
+- Redis 6.2.9 - Released Mon Jan 16 12:00:00 IDT 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Tue Dec 13 2022 Remi Collet <remi@remirepo.net> - 6.2.8-1
+- Redis 6.2.8 - Released Mon 12 Dec 2022 12:00:00 IST
+- Upgrade urgency: MODERATE, Contains fixes for a few non-critical or
+ unlikely bugs
+
+* Wed Apr 27 2022 Remi Collet <remi@remirepo.net> - 6.2.7-1
+- Redis 6.2.7 - Released Wed Apr 27 12:00:00 IDT 2022
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
* Tue Mar 22 2022 Remi Collet <remi@remirepo.net> - 6.2.6-2
- F36 build