summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--redis.spec38
1 files changed, 30 insertions, 8 deletions
diff --git a/redis.spec b/redis.spec
index 837a923..32754a6 100644
--- a/redis.spec
+++ b/redis.spec
@@ -9,6 +9,9 @@
#
%global _hardened_build 1
+# temp workaround to https://bugzilla.redhat.com/2059488
+%undefine _package_note_file
+
# to use system libjemalloc
%bcond_with jemalloc
@@ -34,9 +37,9 @@
%bcond_with tests
# Pre-version are only available in github
-%global upstream_ver 6.0.16
+%global upstream_ver 6.0.20
#global upstream_pre RC4
-%global gh_commit f092dd3227cc74978853e379c0a7731bdaa324af
+%global gh_commit 281af38767956c125d237ff4015485516bcfaf23
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner redis
%global gh_project redis
@@ -44,7 +47,7 @@
# Commit IDs for the (unversioned) redis-doc repository
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
# https://github.com/redis/redis-doc/commits/master
-%global doc_commit 3fdb6df44ecd5c4d99ea52a0133177f5ebc24805
+%global doc_commit ab025f62797f2622ddad7bad938e747bebb6ab09
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
# %%{_rpmmacrodir} not usable on EL-6 - EL-7 (without epel-rpms-macros)
@@ -55,7 +58,10 @@ Version: %{upstream_ver}%{?upstream_pre:~%{upstream_pre}}
Release: 1%{?dist}
Summary: A persistent key-value database
Group: Applications/Databases
-License: BSD
+# redis, hiredis: BSD-3-Clause
+# jemalloc, lzf, linenoise: BSD-2-Clause
+# lua: MIT
+License: BSD-3-Clause AND BSD-2-Clause AND MIT
URL: http://redis.io
%if 0%{?upstream_pre:1}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{upstream_ver}%{upstream_pre}-%{gh_short}.tar.gz
@@ -179,7 +185,7 @@ API documentation is available in the redis-doc package.
%package doc
Summary: Documentation for Redis including man pages
-License: CC-BY-SA
+License: CC-BY-SA-4.0
BuildArch: noarch
# http://fedoraproject.org/wiki/Packaging:Conflicts "Splitting Packages"
@@ -208,9 +214,9 @@ and removal, status checks, resharding, rebalancing, and other operations.
%setup -q -b 10
%endif
mv ../%{name}-doc-%{doc_commit} doc
-%patch0001 -p1
-%patch0002 -p1
-%patch0003 -p1
+%patch -P0001 -p1
+%patch -P0002 -p1
+%patch -P0003 -p1
%if %{with jemalloc}
rm -frv deps/jemalloc
@@ -458,6 +464,22 @@ fi
%changelog
+* Mon Jul 10 2023 Remi Collet <remi@remirepo.net> - 6.0.20-1
+- Redis 6.0.20 Released Mon July 10 12:00:00 IDT 2023
+- Upgrade urgency SECURITY
+
+* Tue Apr 18 2023 Remi Collet <remi@remirepo.net> - 6.0.19-1
+- Redis 6.0.19 Released Mon Apr 17 16:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 6.0.18-1
+- Redis 6.0.18 Released Tue Feb 28 12:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Tue Jan 17 2023 Remi Collet <remi@remirepo.net> - 6.0.17-1
+- Redis 6.0.17 - Released Tue Jan 17 12:00:00 IDT 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
* Mon Oct 4 2021 Remi Collet <remi@remirepo.net> - 6.0.16-1
- Redis 6.0.16 - Released Mon Oct 4 12:00:00 IDT 2021
- Upgrade urgency: SECURITY, contains fixes to security issues.