summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--redis.spec80
1 files changed, 65 insertions, 15 deletions
diff --git a/redis.spec b/redis.spec
index 3127d9f..32754a6 100644
--- a/redis.spec
+++ b/redis.spec
@@ -9,6 +9,9 @@
#
%global _hardened_build 1
+# temp workaround to https://bugzilla.redhat.com/2059488
+%undefine _package_note_file
+
# to use system libjemalloc
%bcond_with jemalloc
@@ -34,17 +37,17 @@
%bcond_with tests
# Pre-version are only available in github
-%global upstream_ver 6.0.10
+%global upstream_ver 6.0.20
#global upstream_pre RC4
-%global gh_commit f092dd3227cc74978853e379c0a7731bdaa324af
+%global gh_commit 281af38767956c125d237ff4015485516bcfaf23
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner antirez
+%global gh_owner redis
%global gh_project redis
# Commit IDs for the (unversioned) redis-doc repository
# https://fedoraproject.org/wiki/Packaging:SourceURL "Commit Revision"
-# https://github.com/antirez/redis-doc/commits/master
-%global doc_commit 8d4bf9bc476829a84a055c049be72634d6e938df
+# https://github.com/redis/redis-doc/commits/master
+%global doc_commit ab025f62797f2622ddad7bad938e747bebb6ab09
%global short_doc_commit %(c=%{doc_commit}; echo ${c:0:7})
# %%{_rpmmacrodir} not usable on EL-6 - EL-7 (without epel-rpms-macros)
@@ -55,7 +58,10 @@ Version: %{upstream_ver}%{?upstream_pre:~%{upstream_pre}}
Release: 1%{?dist}
Summary: A persistent key-value database
Group: Applications/Databases
-License: BSD
+# redis, hiredis: BSD-3-Clause
+# jemalloc, lzf, linenoise: BSD-2-Clause
+# lua: MIT
+License: BSD-3-Clause AND BSD-2-Clause AND MIT
URL: http://redis.io
%if 0%{?upstream_pre:1}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{upstream_ver}%{upstream_pre}-%{gh_short}.tar.gz
@@ -71,7 +77,7 @@ Source6: %{name}-shutdown
Source7: %{name}-limit-systemd
Source8: %{name}-limit-init
Source9: macros.%{name}
-Source10: https://github.com/antirez/%{name}-doc/archive/%{doc_commit}/%{name}-doc-%{short_doc_commit}.tar.gz
+Source10: https://github.com/redis/%{name}-doc/archive/%{doc_commit}/%{name}-doc-%{short_doc_commit}.tar.gz
# To refresh patches:
# tar xf redis-xxx.tar.gz && cd redis-xxx && git init && git add . && git commit -m "%%{version} baseline"
@@ -79,11 +85,11 @@ Source10: https://github.com/antirez/%{name}-doc/archive/%{doc_commit}/
# Then refresh your patches
# git format-patch HEAD~<number of expected patches>
# Update configuration for Fedora
-# https://github.com/antirez/redis/pull/3491 - man pages
+# https://github.com/redis/redis/pull/3491 - man pages
Patch0001: 0001-1st-man-pageis-for-redis-cli-redis-benchmark-redis-c.patch
-# https://github.com/antirez/redis/pull/3494 - symlink
+# https://github.com/redis/redis/pull/3494 - symlink
Patch0002: 0002-install-redis-check-rdb-as-a-symlink-instead-of-dupl.patch
-# https://github.com/antirez/redis/pull/8058 - config rewrite
+# https://github.com/redis/redis/pull/8058 - config rewrite
Patch0003: 0003-Fix-8051-use-old-way-as-fallback-to-save-configurati.patch
@@ -179,7 +185,7 @@ API documentation is available in the redis-doc package.
%package doc
Summary: Documentation for Redis including man pages
-License: CC-BY-SA
+License: CC-BY-SA-4.0
BuildArch: noarch
# http://fedoraproject.org/wiki/Packaging:Conflicts "Splitting Packages"
@@ -208,9 +214,9 @@ and removal, status checks, resharding, rebalancing, and other operations.
%setup -q -b 10
%endif
mv ../%{name}-doc-%{doc_commit} doc
-%patch0001 -p1
-%patch0002 -p1
-%patch0003 -p1
+%patch -P0001 -p1
+%patch -P0002 -p1
+%patch -P0003 -p1
%if %{with jemalloc}
rm -frv deps/jemalloc
@@ -352,7 +358,7 @@ install -pDm644 %{S:9} %{buildroot}%{macrosdir}/macros.%{name}
sed -e '/memefficiency/d' -i tests/test_helper.tcl
%endif
-# https://github.com/antirez/redis/issues/1417 (for "taskset -c 1")
+# https://github.com/redis/redis/issues/1417 (for "taskset -c 1")
taskset -c 1 make %{make_flags} test
make %{make_flags} test-sentinel
%else
@@ -446,6 +452,7 @@ fi
%{macrosdir}/*
%files doc
+%license doc/LICENSE
%docdir %{_docdir}/%{name}
%{_docdir}/%{name}
@@ -457,6 +464,49 @@ fi
%changelog
+* Mon Jul 10 2023 Remi Collet <remi@remirepo.net> - 6.0.20-1
+- Redis 6.0.20 Released Mon July 10 12:00:00 IDT 2023
+- Upgrade urgency SECURITY
+
+* Tue Apr 18 2023 Remi Collet <remi@remirepo.net> - 6.0.19-1
+- Redis 6.0.19 Released Mon Apr 17 16:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 6.0.18-1
+- Redis 6.0.18 Released Tue Feb 28 12:00:00 IST 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Tue Jan 17 2023 Remi Collet <remi@remirepo.net> - 6.0.17-1
+- Redis 6.0.17 - Released Tue Jan 17 12:00:00 IDT 2023
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Mon Oct 4 2021 Remi Collet <remi@remirepo.net> - 6.0.16-1
+- Redis 6.0.16 - Released Mon Oct 4 12:00:00 IDT 2021
+- Upgrade urgency: SECURITY, contains fixes to security issues.
+
+* Thu Jul 22 2021 Remi Collet <remi@remirepo.net> - 6.0.15-1
+- Redis 6.0.15 - Released Wed Jul 21 16:32:19 IDT 2021
+- Upgrade urgency: SECURITY, contains fixes to security issues that affect
+ authenticated client connections on 32-bit versions. MODERATE otherwise.
+
+* Wed Jun 2 2021 Remi Collet <remi@remirepo.net> - 6.0.14-1
+- Redis 6.0.14 - Released Tue June 1 12:00:00 IST 2021
+- Upgrade urgency: SECURITY, Contains fixes to security issues that affect
+ authenticated client connections. MODERATE otherwise.
+
+* Tue May 4 2021 Remi Collet <remi@remirepo.net> - 6.0.13-1
+- Redis 6.0.13 - Released Mon May 3 19:00:00 IST 2021
+- Upgrade urgency: SECURITY, Contains fixes to security issues that affect
+ authenticated client connections. LOW otherwise.
+
+* Tue Mar 2 2021 Remi Collet <remi@remirepo.net> - 6.0.12-1
+- Redis 6.0.12 - Released Mon Mar 1 17:29:52 IST 2021
+- Upgrade urgency: LOW, fixes a compilation issue.
+
+* Tue Feb 23 2021 Remi Collet <remi@remirepo.net> - 6.0.11-1
+- Redis 6.0.11 - Released Mon Feb 22 16:13:23 IST 2021
+- Upgrade urgency: SECURITY if you use 32bit build of redis, LOW otherwise.
+
* Tue Jan 12 2021 Remi Collet <remi@remirepo.net> - 6.0.10-1
- Redis 6.0.10 - Released Tue Jan 12 16:20:20 IST 2021
- Upgrade urgency MODERATE: several bugs with moderate impact are fixed.