summaryrefslogtreecommitdiffstats
path: root/0002-redis-4.0-deps-library-fPIC-performance-tuning.patch
diff options
context:
space:
mode:
Diffstat (limited to '0002-redis-4.0-deps-library-fPIC-performance-tuning.patch')
-rw-r--r--0002-redis-4.0-deps-library-fPIC-performance-tuning.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/0002-redis-4.0-deps-library-fPIC-performance-tuning.patch b/0002-redis-4.0-deps-library-fPIC-performance-tuning.patch
new file mode 100644
index 0000000..b2ddf22
--- /dev/null
+++ b/0002-redis-4.0-deps-library-fPIC-performance-tuning.patch
@@ -0,0 +1,24 @@
+diff -up ./deps/linenoise/Makefile.pic ./deps/linenoise/Makefile
+--- ./deps/linenoise/Makefile.pic 2015-12-23 13:35:32.000000000 +0100
++++ ./deps/linenoise/Makefile 2016-01-15 16:44:52.561582851 +0100
+@@ -2,7 +2,7 @@ STD=
+ WARN= -Wall
+ OPT= -Os
+
+-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
++R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
+ R_LDFLAGS= $(LDFLAGS)
+ DEBUG= -g
+
+diff -up ./deps/Makefile.pic ./deps/Makefile
+--- ./deps/Makefile.pic 2015-12-23 13:35:32.000000000 +0100
++++ ./deps/Makefile 2016-01-15 16:44:52.561582851 +0100
+@@ -59,7 +59,7 @@ ifeq ($(uname_S),SunOS)
+ LUA_CFLAGS= -D__C99FEATURES__=1
+ endif
+
+-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS)
++LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS) -fPIC
+ LUA_LDFLAGS+= $(LDFLAGS)
+ # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
+ # challenging to cross-compile lua (and redis). These defines make it easier