summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-24 09:56:23 +0200
committerRemi Collet <remi@remirepo.net>2017-06-24 09:56:23 +0200
commit43a916d92fb43050addde691d64eb1f4df91f50a (patch)
tree012308ca6cc0ae52895b9ef4e58959d6f9dc8a66
parent36abf988b092231fed509918032d0b17bf2f7769 (diff)
apply some fedora changes
-rw-r--r--redis-dev.spec11
-rw-r--r--redis-sentinel.service2
-rw-r--r--redis-shutdown7
-rw-r--r--redis.service2
-rw-r--r--redis.spec11
5 files changed, 22 insertions, 11 deletions
diff --git a/redis-dev.spec b/redis-dev.spec
index 98d1345..39fed25 100644
--- a/redis-dev.spec
+++ b/redis-dev.spec
@@ -28,7 +28,7 @@
Name: redis
Version: 4.0.0
-Release: 0.3.%{prever}%{?dist}
+Release: 0.4.%{prever}%{?dist}
Summary: A persistent key-value database
Group: Applications/Databases
@@ -58,10 +58,7 @@ Patch3: %{name}-pr3491.patch
# https://github.com/antirez/redis/pull/3494 - symlink
Patch4: %{name}-pr3494.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%if !0%{?el5}
BuildRequires: tcl >= 8.5
-%endif
BuildRequires: jemalloc-devel
# Required for redis-shutdown
@@ -244,7 +241,6 @@ fi
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README.md
@@ -273,6 +269,11 @@ fi
%changelog
+* Sat Jun 24 2017 Remi Collet <remi@remirepo.net> - 4.0.0-0.4.RC3
+- rebuild with some fedora changes:
+ - Add RuntimeDirectory=redis to systemd unit file (RHBZ #1454700)
+ - Fix a shutdown failure with Unix domain sockets (RHBZ #1444988)
+
* Mon Apr 24 2017 Remi Collet <remi@fedoraproject.org> - 4.0.0-0.3.RC3
- update to 4.0.0-RC3 (3.9.103)
diff --git a/redis-sentinel.service b/redis-sentinel.service
index 47b3e53..847a1ab 100644
--- a/redis-sentinel.service
+++ b/redis-sentinel.service
@@ -7,6 +7,8 @@ ExecStart=/usr/bin/redis-sentinel /etc/redis-sentinel.conf --daemonize no
ExecStop=/usr/libexec/redis-shutdown redis-sentinel
User=redis
Group=redis
+RuntimeDirectory=redis
+RuntimeDirectoryMode=0750
[Install]
WantedBy=multi-user.target
diff --git a/redis-shutdown b/redis-shutdown
index 57f21af..53b9f09 100644
--- a/redis-shutdown
+++ b/redis-shutdown
@@ -18,6 +18,7 @@ CONFIG_FILE="/etc/$SERVICE_NAME.conf"
HOST=`awk '/^[[:blank:]]*bind/ { print $2 }' $CONFIG_FILE | tail -n1`
PORT=`awk '/^[[:blank:]]*port/ { print $2 }' $CONFIG_FILE | tail -n1`
PASS=`awk '/^[[:blank:]]*requirepass/ { print $2 }' $CONFIG_FILE | tail -n1`
+SOCK=`awk '/^[[:blank:]]*unixsocket\s/ { print $2 }' $CONFIG_FILE | tail -n1`
# Just in case, use default host, port
HOST=${HOST:-127.0.0.1}
@@ -32,4 +33,8 @@ fi
[ -z "$PASS" ] || ADDITIONAL_PARAMS="-a $PASS"
# shutdown the service properly
-$REDIS_CLI -h $HOST -p $PORT $ADDITIONAL_PARAMS shutdown
+if [ -e "$SOCK" ] ; then
+ $REDIS_CLI -s $SOCK $ADDITIONAL_PARAMS shutdown
+else
+ $REDIS_CLI -h $HOST -p $PORT $ADDITIONAL_PARAMS shutdown
+fi
diff --git a/redis.service b/redis.service
index 0e4eed0..e01dbfe 100644
--- a/redis.service
+++ b/redis.service
@@ -7,6 +7,8 @@ ExecStart=/usr/bin/redis-server /etc/redis.conf --daemonize no
ExecStop=/usr/libexec/redis-shutdown
User=redis
Group=redis
+RuntimeDirectory=redis
+RuntimeDirectoryMode=0750
[Install]
WantedBy=multi-user.target
diff --git a/redis.spec b/redis.spec
index 5bb025d..d7a77b2 100644
--- a/redis.spec
+++ b/redis.spec
@@ -28,7 +28,7 @@
Name: redis
Version: 3.2.9
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A persistent key-value database
Group: Applications/Databases
@@ -58,10 +58,7 @@ Patch3: %{name}-pr3491.patch
# https://github.com/antirez/redis/pull/3494 - symlink
Patch4: %{name}-pr3494.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%if !0%{?el5}
BuildRequires: tcl >= 8.5
-%endif
BuildRequires: jemalloc-devel
# Required for redis-shutdown
@@ -240,7 +237,6 @@ fi
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README.md
@@ -269,6 +265,11 @@ fi
%changelog
+* Sat Jun 24 2017 Remi Collet <remi@remirepo.net> - 3.2.9-2
+- rebuild with latest fedora changes
+ - Add RuntimeDirectory=redis to systemd unit file (RHBZ #1454700)
+ - Fix a shutdown failure with Unix domain sockets (RHBZ #1444988)
+
* Sun May 21 2017 Remi Collet <remi@remirepo.net> - 3.2.9-1
- Redis 3.2.9 - Released Mon May 17 17:35:38 CEST 2017
- Upgrade urgency LOW: A few rarely harmful bugs were fixed.