summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-04 19:59:36 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-04 19:59:36 +0100
commite1117f76ed85f10a46d861cdff0b0c82c23cf1f6 (patch)
treec9bbe997a6af685836c150f71e9c8578f21bcccd
parente6733b88c58b2919f50e995e06dfe761f8df2a09 (diff)
redis 2.8.18
-rw-r--r--0001-redis-2.8.18-redis-conf.patch (renamed from redis-2.8.15-conf.patch)14
-rw-r--r--0002-redis-2.8.18-deps-library-fPIC-performance-tuning.patch24
-rw-r--r--0003-redis-2.8.11-use-system-jemalloc.patch (renamed from redis-deps-unbundle-jemalloc.patch)0
-rw-r--r--redis-deps-PIC.patch23
-rw-r--r--redis.spec14
5 files changed, 40 insertions, 35 deletions
diff --git a/redis-2.8.15-conf.patch b/0001-redis-2.8.18-redis-conf.patch
index fc5e343..44ef765 100644
--- a/redis-2.8.15-conf.patch
+++ b/0001-redis-2.8.18-redis-conf.patch
@@ -1,6 +1,6 @@
-diff -up redis-2.8.15/redis.conf.rpmconf redis-2.8.15/redis.conf
---- redis-2.8.15/redis.conf.rpmconf 2014-09-12 16:16:58.000000000 +0200
-+++ redis-2.8.15/redis.conf 2014-09-12 17:46:45.918482580 +0200
+diff -up redis-2.8.18/redis.conf.rpmconf redis-2.8.18/redis.conf
+--- redis-2.8.18/redis.conf.rpmconf 2014-12-04 11:36:52.000000000 +0100
++++ redis-2.8.18/redis.conf 2014-12-04 19:39:55.101325437 +0100
@@ -62,6 +62,7 @@ tcp-backlog 511
#
# bind 192.168.1.100 10.0.0.1
@@ -20,16 +20,16 @@ diff -up redis-2.8.15/redis.conf.rpmconf redis-2.8.15/redis.conf
# and optionally update the other syslog parameters to suit your needs.
@@ -184,7 +185,7 @@ dbfilename dump.rdb
# The Append Only File will also be created inside this directory.
- #
+ #
# Note that you must specify a directory here, not a file name.
-dir ./
+dir /var/lib/redis/
################################# REPLICATION #################################
-diff -up redis-2.8.15/sentinel.conf.rpmconf redis-2.8.15/sentinel.conf
---- redis-2.8.15/sentinel.conf.rpmconf 2014-09-12 17:46:45.918482580 +0200
-+++ redis-2.8.15/sentinel.conf 2014-09-12 17:47:39.512717702 +0200
+diff -up redis-2.8.18/sentinel.conf.rpmconf redis-2.8.18/sentinel.conf
+--- redis-2.8.18/sentinel.conf.rpmconf 2014-12-04 11:36:52.000000000 +0100
++++ redis-2.8.18/sentinel.conf 2014-12-04 19:39:21.949190312 +0100
@@ -4,6 +4,11 @@
# The port that this sentinel instance will run on
port 26379
diff --git a/0002-redis-2.8.18-deps-library-fPIC-performance-tuning.patch b/0002-redis-2.8.18-deps-library-fPIC-performance-tuning.patch
new file mode 100644
index 0000000..a9b68d7
--- /dev/null
+++ b/0002-redis-2.8.18-deps-library-fPIC-performance-tuning.patch
@@ -0,0 +1,24 @@
+diff -up redis-2.8.18/deps/linenoise/Makefile.pic redis-2.8.18/deps/linenoise/Makefile
+--- redis-2.8.18/deps/linenoise/Makefile.pic 2014-12-04 11:36:52.000000000 +0100
++++ redis-2.8.18/deps/linenoise/Makefile 2014-12-04 19:41:57.437824019 +0100
+@@ -2,7 +2,7 @@ STD=
+ WARN= -Wall
+ OPT= -Os
+
+-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
++R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
+ R_LDFLAGS= $(LDFLAGS)
+ DEBUG= -g
+
+diff -up redis-2.8.18/deps/Makefile.pic redis-2.8.18/deps/Makefile
+--- redis-2.8.18/deps/Makefile.pic 2014-12-04 19:41:57.437824019 +0100
++++ redis-2.8.18/deps/Makefile 2014-12-04 19:43:26.346186323 +0100
+@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
+ LUA_CFLAGS= -D__C99FEATURES__=1
+ endif
+
+-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL $(CFLAGS)
++LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL $(CFLAGS) -fPIC
+ LUA_LDFLAGS+= $(LDFLAGS)
+ # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
+ # challenging to cross-compile lua (and redis). These defines make it easier
diff --git a/redis-deps-unbundle-jemalloc.patch b/0003-redis-2.8.11-use-system-jemalloc.patch
index cf1b231..cf1b231 100644
--- a/redis-deps-unbundle-jemalloc.patch
+++ b/0003-redis-2.8.11-use-system-jemalloc.patch
diff --git a/redis-deps-PIC.patch b/redis-deps-PIC.patch
deleted file mode 100644
index d29cdfa..0000000
--- a/redis-deps-PIC.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/deps/Makefile.pic 2014-09-04 20:14:53.780910375 +0200
-+++ a/deps/Makefile 2014-09-04 20:15:49.278133046 +0200
-@@ -58,7 +58,7 @@
- LUA_CFLAGS= -D__C99FEATURES__=1
- endif
-
--LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
-+LUA_CFLAGS+= -O2 -Wall -fPIC -DLUA_ANSI $(CFLAGS)
- LUA_LDFLAGS+= $(LDFLAGS)
- # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
- # challenging to cross-compile lua (and redis). These defines make it easier
---- a/deps/linenoise/Makefile
-+++ a/deps/linenoise/Makefile
-@@ -2,7 +2,7 @@ STD=
- WARN= -Wall
- OPT= -Os
-
--R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
-+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
- R_LDFLAGS= $(LDFLAGS)
- DEBUG= -g
-
-
diff --git a/redis.spec b/redis.spec
index 38d1b72..3b6e278 100644
--- a/redis.spec
+++ b/redis.spec
@@ -10,8 +10,8 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: redis
-Version: 2.8.17
-Release: 2%{?dist}
+Version: 2.8.18
+Release: 1%{?dist}
Summary: A persistent key-value database
Group: Applications/Databases
@@ -26,9 +26,9 @@ Source5: %{name}-sentinel.init
Source6: %{name}-sentinel.service
Source7: %{name}-shutdown
# Update configuration for Fedora
-Patch0: %{name}-2.8.15-conf.patch
-Patch1: %{name}-deps-PIC.patch
-Patch2: %{name}-deps-unbundle-jemalloc.patch
+Patch0: 0001-redis-2.8.18-redis-conf.patch
+Patch1: 0002-redis-2.8.18-deps-library-fPIC-performance-tuning.patch
+Patch2: 0003-redis-2.8.11-use-system-jemalloc.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%if !0%{?el5}
@@ -218,6 +218,10 @@ fi
%changelog
+* Thu Dec 4 2014 Remi Collet <remi@fedoraproject.org> - 2.8.18-1
+- Redis 2.8.18 - Release date: 4 Dec 2014
+ upgrade urgency: LOW for both Redis and Sentinel.
+
* Sun Sep 21 2014 Remi Collet <remi@fedoraproject.org> - 2.8.17-2
- fix sentinel service unit file for systemd
- also use redis-shutdown in init scripts