summaryrefslogtreecommitdiffstats
path: root/0003-redis-2.8.11-use-system-jemalloc.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-04 19:59:36 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-04 19:59:36 +0100
commite1117f76ed85f10a46d861cdff0b0c82c23cf1f6 (patch)
treec9bbe997a6af685836c150f71e9c8578f21bcccd /0003-redis-2.8.11-use-system-jemalloc.patch
parente6733b88c58b2919f50e995e06dfe761f8df2a09 (diff)
redis 2.8.18
Diffstat (limited to '0003-redis-2.8.11-use-system-jemalloc.patch')
-rw-r--r--0003-redis-2.8.11-use-system-jemalloc.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/0003-redis-2.8.11-use-system-jemalloc.patch b/0003-redis-2.8.11-use-system-jemalloc.patch
new file mode 100644
index 0000000..cf1b231
--- /dev/null
+++ b/0003-redis-2.8.11-use-system-jemalloc.patch
@@ -0,0 +1,14 @@
+--- a/src/Makefile 2013-04-30 15:15:56.000000000 +0200
++++ b/src/Makefile 2013-06-19 12:58:12.345612310 +0200
+@@ -89,9 +89,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
+ endif
+
+ ifeq ($(MALLOC),jemalloc)
+- DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
++ FINAL_LIBS+= -ljemalloc -ldl
+ endif
+
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)