summaryrefslogtreecommitdiffstats
path: root/pie.spec
diff options
context:
space:
mode:
Diffstat (limited to 'pie.spec')
-rw-r--r--pie.spec18
1 files changed, 10 insertions, 8 deletions
diff --git a/pie.spec b/pie.spec
index a3bacbd..8d9f8f6 100644
--- a/pie.spec
+++ b/pie.spec
@@ -10,17 +10,16 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit bbb9b6b44b9d9f57d710912e545a4371da2c00e9
+%global gh_commit 51f0d5072d7346c90d20bf9a5633e67938fefcca
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20241003
+#global gh_date 20241003
%global gh_branch main
%global gh_owner php
%global gh_project pie
-# nightly tarball reports as 0.0.0
-%global upstream_version 0.0.0
-%global upstream_prever dev
-%global upstream_lower DEV
+%global upstream_version 0.1.0
+#global upstream_prever dev
+#global upstream_lower DEV
%global bashcompdir %(pkg-config --variable=completionsdir bash-completion 2>/dev/null)
%global bashcomproot %(dirname %{bashcompdir} 2>/dev/null)
@@ -51,7 +50,7 @@ BuildRequires: php-zip
BuildRequires: pkgconfig(bash-completion)
# From composer.json, "require": {
-# "php": "8.1.*||8.2.*||8.3.*",
+# "php": "8.1.*||8.2.*||8.3.*||8.4.*",
# "ext-zip": "*",
Requires: php(language) >= 8.1
Requires: php-cli
@@ -133,7 +132,7 @@ Documentation: /usr/share/doc/pie/docs/usage.md
find . \( -name \*.rpm -o -name \*noxdg \) -delete -print
: Set version
-sed -e 's/@pie_version@/%{upstream_version}%{upstream_prever}/' -i bin/pie
+sed -e 's/@pie_version@/%{upstream_version}%{?upstream_prever}/' -i bin/pie
: List bundled libraries and Licenses
php -r '
@@ -193,5 +192,8 @@ done
%changelog
+* Thu Oct 10 2024 Remi Collet <remi@remirepo.net> - 0.1.0-1
+- update to 0.1.0 (pre-release)
+
* Fri Oct 4 2024 Remi Collet <remi@remirepo.net> - 0.0.0~DEV-1.20241003.bbb9b6b
- Initial package from dev-main