summaryrefslogtreecommitdiffstats
path: root/phpunit7.spec
diff options
context:
space:
mode:
Diffstat (limited to 'phpunit7.spec')
-rw-r--r--phpunit7.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/phpunit7.spec b/phpunit7.spec
index 0b97cd3..94117a1 100644
--- a/phpunit7.spec
+++ b/phpunit7.spec
@@ -258,8 +258,11 @@ sed -e 's:%{php_home}/%{ns_vendor}:%{buildroot}%{php_home}/%{ns_vendor}:' -i php
ret=0
# TODO 7.4: Exception: Serialization of 'ReflectionClass' is not allowed
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
+ if [ $($cmd -r 'echo PHP_VERSION_ID;') -ge 70400 ]; then
+ OPT="$OPT --filter '^((?!(testStaticAttributesBackupPre)).)*$'"
+ fi
$cmd ./phpunit $OPT --verbose || ret=1
fi
done