summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-timer2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-timer2.spec')
-rw-r--r--php-phpunit-php-timer2.spec15
1 files changed, 8 insertions, 7 deletions
diff --git a/php-phpunit-php-timer2.spec b/php-phpunit-php-timer2.spec
index 2e9ee95..05fbf6f 100644
--- a/php-phpunit-php-timer2.spec
+++ b/php-phpunit-php-timer2.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 8b389aebe1b8b0578430bda0c7c95a829608e059
+%global gh_commit 1038454804406b0b5f5f520358e78c1c2f71501e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -28,16 +28,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.1.1
-Release: 2%{?dist}
+Version: 2.1.2
+Release: 1%{?dist}
Summary: PHP Utility class for timing
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/php-timer/pull/21.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 7.1
BuildRequires: php-fedora-autoloader-devel
@@ -65,7 +63,6 @@ component.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -87,7 +84,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
%{_bindir}/phpunit7 --verbose || ret=1
@@ -108,6 +105,10 @@ exit $ret
%changelog
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 2.1.2-1
+- update to 2.1.2
+- drop patch merged upstream
+
* Wed Feb 20 2019 Remi Collet <remi@remirepo.net> - 2.1.1-2
- add patch from https://github.com/sebastianbergmann/php-timer/pull/21
fix for 32-bit where large value are converted to float