summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--21.patch70
-rw-r--r--php-phpunit-php-timer2.spec15
2 files changed, 8 insertions, 77 deletions
diff --git a/21.patch b/21.patch
deleted file mode 100644
index c633abd..0000000
--- a/21.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From d07774e18e532336361f2b59c039099fae512898 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 20 Feb 2019 14:52:09 +0100
-Subject: [PATCH 1/2] fix for 32-bit where large value are converted to float
-
----
- src/Timer.php | 4 ++--
- tests/TimerTest.php | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/Timer.php b/src/Timer.php
-index 8f919b6..9ad76dc 100644
---- a/src/Timer.php
-+++ b/src/Timer.php
-@@ -44,7 +44,7 @@ public static function stop(): float
- return \microtime(true) - \array_pop(self::$startTimes);
- }
-
-- public static function bytesToString(int $bytes): string
-+ public static function bytesToString(float $bytes): string
- {
- foreach (self::$sizes as $unit => $value) {
- if ($bytes >= $value) {
-@@ -54,7 +54,7 @@ public static function bytesToString(int $bytes): string
- }
- }
-
-- return $bytes . ' byte' . ($bytes !== 1 ? 's' : '');
-+ return $bytes . ' byte' . ((int)$bytes !== 1 ? 's' : '');
- }
-
- public static function secondsToTimeString(float $time): string
-diff --git a/tests/TimerTest.php b/tests/TimerTest.php
-index e8cf7ef..93cc474 100644
---- a/tests/TimerTest.php
-+++ b/tests/TimerTest.php
-@@ -112,7 +112,7 @@ public function secondsProvider(): array
- /**
- * @dataProvider bytesProvider
- */
-- public function testCanFormatBytesAsString(string $string, int $bytes): void
-+ public function testCanFormatBytesAsString(string $string, float $bytes): void
- {
- $this->assertEquals($string, Timer::bytesToString($bytes));
- }
-
-From 9398c85d883eec73ab9fddb4d72d42091425791b Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 20 Feb 2019 15:02:00 +0100
-Subject: [PATCH 2/2] simplify code
-
----
- src/Timer.php | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/src/Timer.php b/src/Timer.php
-index 9ad76dc..c78a6ee 100644
---- a/src/Timer.php
-+++ b/src/Timer.php
-@@ -48,9 +48,7 @@ public static function bytesToString(float $bytes): string
- {
- foreach (self::$sizes as $unit => $value) {
- if ($bytes >= $value) {
-- $size = \sprintf('%.2f', $bytes >= 1024 ? $bytes / $value : $bytes);
--
-- return $size . ' ' . $unit;
-+ return \sprintf('%.2f %s', $bytes >= 1024 ? $bytes / $value : $bytes, $unit);
- }
- }
-
diff --git a/php-phpunit-php-timer2.spec b/php-phpunit-php-timer2.spec
index 2e9ee95..05fbf6f 100644
--- a/php-phpunit-php-timer2.spec
+++ b/php-phpunit-php-timer2.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 8b389aebe1b8b0578430bda0c7c95a829608e059
+%global gh_commit 1038454804406b0b5f5f520358e78c1c2f71501e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -28,16 +28,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.1.1
-Release: 2%{?dist}
+Version: 2.1.2
+Release: 1%{?dist}
Summary: PHP Utility class for timing
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-Patch0: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/php-timer/pull/21.patch
-
BuildArch: noarch
BuildRequires: php(language) >= 7.1
BuildRequires: php-fedora-autoloader-devel
@@ -65,7 +63,6 @@ component.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -87,7 +84,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
%{_bindir}/phpunit7 --verbose || ret=1
@@ -108,6 +105,10 @@ exit $ret
%changelog
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 2.1.2-1
+- update to 2.1.2
+- drop patch merged upstream
+
* Wed Feb 20 2019 Remi Collet <remi@remirepo.net> - 2.1.1-2
- add patch from https://github.com/sebastianbergmann/php-timer/pull/21
fix for 32-bit where large value are converted to float