summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 12:33:06 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 12:33:06 +0200
commita26fe6635e669fb85b80e77e2bd941ca4e173a96 (patch)
tree5efbe8bdbc9eaa641dc3f8f2b1710360b7c6f07e
parent950aeec8cc5c2f1183f880f7ba4a79b70211ad9d (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json35
-rw-r--r--php-zetacomponents-document.spec1
4 files changed, 47 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..34584fb
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "authors": [
+ {
+ "name": "Sebastian Bergmann"
+ },
+ {
+ "name": "Kore Nordmann"
+ },
+ {
+ "name": "Derick Rethans"
+ },
+ {
+ "name": "Tobias Schlitt"
+ },
+ {
+ "name": "Alexandru Stanoi"
+ }
+ ],
+ "autoload": {
+ "classmap": [
+ "src"
+ ]
+ },
+ "description": "The Document components provides a general conversion framework for different semantic document markup languages like XHTML, Docbook, RST and similar.",
+ "homepage": "https://github.com/zetacomponents",
+ "license": "Apache-2.0",
+ "name": "zetacomponents/document",
+ "type": "library",
+ "require": {
+ "zetacomponents/base": "*"
+ },
+ "require-dev": {
+ "zetacomponents/unit-test": "dev-master"
+ }
+}
diff --git a/php-zetacomponents-document.spec b/php-zetacomponents-document.spec
index ee97e82..64ce355 100644
--- a/php-zetacomponents-document.spec
+++ b/php-zetacomponents-document.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-zetacomponents-document
#
# Fedora spec file for php-zetacomponents-document
#