summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zendservice-recaptcha.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-09 15:58:01 +0100
committerRemi Collet <remi@remirepo.net>2017-12-09 15:58:01 +0100
commit73b22f52b38bf6974f16d627a5a925292efa4b65 (patch)
treea71758a5e0c1dbdf730f4d88c486584a4084e3ba /php-zendframework-zendservice-recaptcha.spec
parente9cb0a09e5c83f45294882930792427f4ef7e7d7 (diff)
cleanup
Diffstat (limited to 'php-zendframework-zendservice-recaptcha.spec')
-rw-r--r--php-zendframework-zendservice-recaptcha.spec28
1 files changed, 6 insertions, 22 deletions
diff --git a/php-zendframework-zendservice-recaptcha.spec b/php-zendframework-zendservice-recaptcha.spec
index 818d4bf..ccdafb3 100644
--- a/php-zendframework-zendservice-recaptcha.spec
+++ b/php-zendframework-zendservice-recaptcha.spec
@@ -30,7 +30,6 @@ Source1: makesrc.sh
# See https://github.com/zendframework/ZendService_ReCaptcha/pull/12
Patch0: %{name}-pr12.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -99,8 +98,6 @@ ln -s ../../Zend/autoload.php src/autoload.php
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/%{namespace}
cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
@@ -119,33 +116,20 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
'%{namespace}\\%{library}' => '%{buildroot}%{php_home}/%{namespace}/%{library}',
))));
EOF
-# remirepo:11
-run=0
+
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --exclude online || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit6 --exclude online || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --exclude online --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --exclude online || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md