summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-06 18:29:32 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-06 18:29:32 +0200
commit73f2a2c14974c17d7e994a7170c5810692f78252 (patch)
treeee0f8da2855c2bced48782d601f5d17644c7e89c
php-zendframework-zendservice-recaptcha: try... broken.. probably dead
-rw-r--r--Makefile3
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-zendframework-zendservice-recaptcha-autoload.php16
-rw-r--r--php-zendframework-zendservice-recaptcha.spec119
4 files changed, 165 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..24fbf81
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-zendframework-zendservice-recaptcha-autoload.php b/php-zendframework-zendservice-recaptcha-autoload.php
new file mode 100644
index 0000000..a0a7585
--- /dev/null
+++ b/php-zendframework-zendservice-recaptcha-autoload.php
@@ -0,0 +1,16 @@
+<?php
+/*
+Simple autoloader for Zend Framework + ZendService components
+Inspired from https://github.com/zendframework/ZendSkeletonApplication
+
+Set autoregister_zf for Zend Framework
+Set fallback_autoloader for dependencies which are PSR-0 compliant
+*/
+require_once '/usr/share/php/Zend//Loader/AutoloaderFactory.php';
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
+ 'fallback_autoloader' => true,
+ 'autoregister_zf' => true,
+ 'namespaces' => array(
+ 'ZendService' => dirname(__DIR__)
+))));
diff --git a/php-zendframework-zendservice-recaptcha.spec b/php-zendframework-zendservice-recaptcha.spec
new file mode 100644
index 0000000..e1dd760
--- /dev/null
+++ b/php-zendframework-zendservice-recaptcha.spec
@@ -0,0 +1,119 @@
+# remirepo spec/Fedora file for php-zendframework-zendservice-recaptcha
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 4324cca8502d9f47b3b43a18acdd3fdbeb965536
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project ZendService_ReCaptcha
+%global pk_project zendservice-recaptcha
+%global php_home %{_datadir}/php
+%global namespace ZendService
+%global library ReCaptcha
+%global with_tests 0%{!?_without_tests:1}
+
+############# TODO seems dead / unmaintained - last commit in 2012 #########
+
+
+Name: php-%{gh_owner}-%{pk_project}
+Version: 2.0.1
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: http://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+Source2: %{name}-autoload.php
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.3.3
+BuildRequires: php-mcrypt
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.0.0
+BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.0.0
+BuildRequires: php-composer(%{gh_owner}/zend-version) >= 2.0.0
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader)
+%endif
+
+# From composer, "require": {
+# "php": ">=5.3.3",
+# "zendframework/zend-http": ">=2.0.0",
+# "zendframework/zend-uri": ">=2.0.0",
+# "zendframework/zend-version": ">=2.0.0"
+Requires: php(language) >= 5.3.3
+Requires: php-composer(%{gh_owner}/zend-http) >= 2.0.0
+Requires: php-composer(%{gh_owner}/zend-uri) >= 2.0.0
+Requires: php-composer(%{gh_owner}/zend-version) >= 2.0.0
+# From phpcompatinfo report for version 2.0.1
+Requires: php-mcrypt
+
+Provides: php-composer(%{gh_owner}/%{pk_project}) = %{version}
+
+
+%description
+%{summary}.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{php_home}
+cp -pr library/%{namespace} %{buildroot}%{php_home}/%{namespace}
+
+install -pm 644 %{SOURCE2} %{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << EOF | tee vendor/autoload.php
+<?php
+require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
+Zend\\Loader\\AutoloaderFactory::factory(array(
+ 'Zend\\Loader\\StandardAutoloader' => array(
+ 'namespaces' => array(
+ 'ZendServiceTest\\\\%{library}' => dirname(__DIR__).'/tests/ZendServiceTest/ReCaptcha'
+))));
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+EOF
+cd tests
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.txt
+%doc README.md
+%doc composer.json
+%{php_home}/%{library}
+
+
+%changelog
+* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- initial package \ No newline at end of file