summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-xmlrpc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-xmlrpc.spec')
-rw-r--r--php-zendframework-zend-xmlrpc.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-zendframework-zend-xmlrpc.spec b/php-zendframework-zend-xmlrpc.spec
index e6974c2..8bb4580 100644
--- a/php-zendframework-zend-xmlrpc.spec
+++ b/php-zendframework-zend-xmlrpc.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b41116f63a0c73c6efc33c3b2f912e868e7172fe
+%global gh_commit 5470f555b336b48fe22db52df973c786a4a146d7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-xmlrpc
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.1
+Version: 2.6.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -48,9 +48,9 @@ BuildRequires: php-composer(%{gh_owner}/zend-server) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zendxml) >= 1.0.2
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^4.8",
-# "squizlabs/php_codesniffer": "^2.3.1"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+# "phpunit/PHPUnit": "^5.7.25 || ^6.4.4",
+# "zendframework/zend-coding-standard": "~1.0.0"
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -135,11 +135,12 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once 'test/autoload.php';
require_once 'test/TestAsset/functions.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php71 php72; do
if which $cmd; then
$cmd %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
fi
@@ -159,6 +160,9 @@ exit $ret
%changelog
+* Fri Jan 26 2018 Remi Collet <remi@remirepo.net> - 2.6.2-1
+- Update to 2.6.2
+
* Fri Aug 11 2017 Remi Collet <remi@remirepo.net> - 2.6.1-1
- Update to 2.6.1