summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-02 06:38:08 +0100
committerRemi Collet <remi@remirepo.net>2018-02-02 06:38:08 +0100
commite75bb48fb49ec5921f8dc205e2edfd1178a9b3bb (patch)
treecffc336e5de84e1206dc1345e24bde68fd0f4d19
parent2f8ebdc3304e5d8bf3f240ebe636fb6e1d48b786 (diff)
v2.10.2
-rw-r--r--composer.json7
-rw-r--r--php-zendframework-zend-validator.spec18
2 files changed, 12 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index a65cf39..17f2915 100644
--- a/composer.json
+++ b/composer.json
@@ -45,8 +45,8 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.10-dev",
- "dev-develop": "2.11-dev"
+ "dev-master": "2.10.x-dev",
+ "dev-develop": "2.11.x-dev"
},
"zf": {
"component": "Zend\\Validator",
@@ -66,7 +66,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index d5173ce..c6dfb83 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-validator
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 010084ddbd33299bf51ea6f0e07f8f4e8bd832a8
+%global gh_commit 38109ed7d8e46cfa71bccbe7e6ca80cdd035f8c9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-validator
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.10.1
-Release: 2%{?dist}
+Version: 2.10.2
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,8 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-validator/pull/205.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -132,7 +130,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr205
mv LICENSE.md LICENSE
@@ -165,10 +162,10 @@ EOF
# PHP 7.2 https://github.com/zendframework/zend-validator/issues/196
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
fi
done
exit $ret
@@ -186,6 +183,9 @@ exit $ret
%changelog
+* Fri Feb 2 2018 Remi Collet <remi@remirepo.net> - 2.10.2-1
+- Update to 2.10.2
+
* Tue Oct 31 2017 Remi Collet <remi@remirepo.net> - 2.10.1-2
- fix FTBFS from Koschei, add patch for test with 7.2 from
https://github.com/zendframework/zend-validator/pull/205