summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-14 07:49:50 +0100
committerRemi Collet <remi@remirepo.net>2018-12-14 07:49:50 +0100
commit9f3f4eaca568cafcdba4ac75fdc913f3ad22a41e (patch)
tree2b6d835afbfcde56df4f134babf40602283fdb28
parentf8347fde8678f6ee7dc0634e7ee681b5dc6dbe31 (diff)
update to 2.11.0
add dependency on psr/http-message
-rw-r--r--composer.json12
-rw-r--r--php-zendframework-zend-validator.spec33
2 files changed, 30 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 17f2915..fc08755 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,10 @@
"container-interop/container-interop": "^1.1"
},
"require-dev": {
+ "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
+ "psr/http-message": "^1.0",
"zendframework/zend-cache": "^2.6.1",
+ "zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-config": "^2.6",
"zendframework/zend-db": "^2.7",
"zendframework/zend-filter": "^2.6",
@@ -27,11 +30,10 @@
"zendframework/zend-math": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
"zendframework/zend-session": "^2.8",
- "zendframework/zend-uri": "^2.5",
- "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "zendframework/zend-uri": "^2.5"
},
"suggest": {
+ "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators",
"zendframework/zend-db": "Zend\\Db component, required by the (No)RecordExists validator",
"zendframework/zend-filter": "Zend\\Filter component, required by the Digits validator",
"zendframework/zend-i18n": "Zend\\I18n component to allow translation of validation error messages",
@@ -45,8 +47,8 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.10.x-dev",
- "dev-develop": "2.11.x-dev"
+ "dev-master": "2.11.x-dev",
+ "dev-develop": "2.12.x-dev"
},
"zf": {
"component": "Zend\\Validator",
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index c6dfb83..e10c95b 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 38109ed7d8e46cfa71bccbe7e6ca80cdd035f8c9
+%global gh_commit f0789b4c4c099afdd2ecc58cc209a26c64bd4f17
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-validator
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.10.2
+Version: 2.11.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -44,7 +44,10 @@ BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.6
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
# From composer, "require-dev": {
+# "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
+# "psr/http-message": "^1.0",
# "zendframework/zend-cache": "^2.6.1",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6",
# "zendframework/zend-db": "^2.7",
# "zendframework/zend-filter": "^2.6",
@@ -53,9 +56,8 @@ BuildRequires: php-composer(container-interop/container-interop) >= 1.1
# "zendframework/zend-math": "^2.6",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-session": "^2.8",
-# "zendframework/zend-uri": "^2.5",
-# "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "zendframework/zend-uri": "^2.5"
+BuildRequires: php-composer(psr/http-message)
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
@@ -87,6 +89,7 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
Requires: php-composer(container-interop/container-interop) >= 1.1
Requires: php-composer(container-interop/container-interop) < 2
# From composer, "suggest": {
+# "psr/http-message": "psr/http-message, required when validating PSR-7 UploadedFileInterface instances via the Upload and UploadFile validators",
# "zendframework/zend-db": "Zend\\Db component, required by the (No)RecordExists validator",
# "zendframework/zend-filter": "Zend\\Filter component, required by the Digits validator",
# "zendframework/zend-i18n": "Zend\\I18n component to allow translation of validation error messages",
@@ -95,6 +98,8 @@ Requires: php-composer(container-interop/container-interop) < 2
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
# "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
# "zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
+# mandatory for our autoloader
+Requires: php-composer(psr/http-message)
%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-db)
Suggests: php-composer(%{gh_owner}/zend-filter)
@@ -135,15 +140,19 @@ mv LICENSE.md LICENSE
%build
-# Empty build section, nothing required
+: Create dependency autoloader
+cat << 'EOF' | tee autoload.php
+<?php
+require_once '%{php_home}/Psr/Http/Message/autoload.php';
+EOF
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+
%check
%if %{with_tests}
@@ -160,9 +169,8 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# PHP 7.2 https://github.com/zendframework/zend-validator/issues/196
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" php70 php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -180,9 +188,14 @@ exit $ret
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/Zend/%{library}-autoload.php
%changelog
+* Fri Dec 14 2018 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- add dependency on psr/http-message
+
* Fri Feb 2 2018 Remi Collet <remi@remirepo.net> - 2.10.2-1
- Update to 2.10.2