summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-18 07:04:44 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-18 07:04:44 +0100
commit8c7765cf7f074f615d018eb221ecb91fdd348e91 (patch)
tree3bfceabdbd00a506548e43edbc91a257efd3ea84
parentbd09e592ee7ddd24cabf829c2e710c74c094fa3f (diff)
php-zendframework-zend-uri: 2.5.2
-rw-r--r--php-zendframework-zend-uri.spec28
1 files changed, 16 insertions, 12 deletions
diff --git a/php-zendframework-zend-uri.spec b/php-zendframework-zend-uri.spec
index d59c43e..a328dc1 100644
--- a/php-zendframework-zend-uri.spec
+++ b/php-zendframework-zend-uri.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit fe6c7f4c8d9037fe551898a538a2b6d39483f572
+%global gh_commit 0bf717a239432b1a1675ae314f7c4acd742749ed
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-uri
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.5.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
@@ -49,10 +49,10 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-escaper": "~2.5",
-# "zendframework/zend-validator": "~2.5"
-Requires: php(language) >= 5.3.23
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-escaper": "^2.5",
+# "zendframework/zend-validator": "^2.5"
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
Requires: php-composer(%{gh_owner}/zend-escaper) < 3
@@ -92,14 +92,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -128,5 +128,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Feb 18 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP >= 5.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
- initial package \ No newline at end of file