summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-servicemanager.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-servicemanager.spec')
-rw-r--r--php-zendframework-zend-servicemanager.spec34
1 files changed, 10 insertions, 24 deletions
diff --git a/php-zendframework-zend-servicemanager.spec b/php-zendframework-zend-servicemanager.spec
index 634b8df..7880515 100644
--- a/php-zendframework-zend-servicemanager.spec
+++ b/php-zendframework-zend-servicemanager.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c3036efb81f71bfa36cc9962ee5d4474f36581d0
+%global gh_commit 0fa3d3cf588dde0850fff1efa60d44a7aa3c3ab7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-servicemanager
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.3.0
+Version: 3.3.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -122,8 +121,6 @@ EOF
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -147,33 +144,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || : ignore
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit6 --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -183,6 +166,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 3.3.1-1
+- Update to 3.3.1
+
* Thu Mar 2 2017 Remi Collet <remi@fedoraproject.org> - 3.3.0-1
- update to 3.3.0
- raise dependency on container-interop/container-interop 1.2