summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-serializer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-15 08:22:28 +0200
committerRemi Collet <remi@remirepo.net>2018-05-15 08:22:28 +0200
commit6fc36b412ca8c26968ae3d387fc771672a44e96d (patch)
treec9174280116e676e7a1306d1e92b428dbc705dad /php-zendframework-zend-serializer.spec
parent411de63ccc25a4ffbfc3bf181cd4a1b2b27eb63c (diff)
v2.9.0
Diffstat (limited to 'php-zendframework-zend-serializer.spec')
-rw-r--r--php-zendframework-zend-serializer.spec24
1 files changed, 13 insertions, 11 deletions
diff --git a/php-zendframework-zend-serializer.spec b/php-zendframework-zend-serializer.spec
index b35b5de..bc5f166 100644
--- a/php-zendframework-zend-serializer.spec
+++ b/php-zendframework-zend-serializer.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7ac42b9a47e9cb23895173a3096bc3b3fb7ac580
+%global gh_commit 0172690db48d8935edaf625c4cba38b79719892c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-serializer
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.1
+Version: 2.9.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -32,7 +32,7 @@ Source1: makesrc.sh
# remirepo:3
# For test build on all available arch
-#global debug_package %{nil}
+#global debug_package %%{nil}
#global __debug_install_post /bin/true
BuildArch: noarch
# Tests
@@ -46,22 +46,21 @@ BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.5
# From composer, "require-dev": {
-# "zendframework/zend-math": "^2.6",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "phpunit/phpunit": "^5.5",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "doctrine/instantiator": "1.0.*"
+# "phpunit/phpunit": "^5.7.25 || ^6.4.4",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-math": "^2.6 || ^3.0",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(phpunit/phpunit) >= 5.5
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
# "zendframework/zend-json": "^2.5 || ^3.0"
+# "zendframework/zend-stdlib": "^2.7 || ^3.0",
Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
@@ -129,7 +128,7 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd %{_bindir}/phpunit || ret=1
fi
@@ -149,6 +148,9 @@ exit $ret
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+
* Tue Nov 21 2017 Remi Collet <remi@remirepo.net> - 2.8.1-1
- Update to 2.8.1