summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-router.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-router.spec')
-rw-r--r--php-zendframework-zend-router.spec91
1 files changed, 63 insertions, 28 deletions
diff --git a/php-zendframework-zend-router.spec b/php-zendframework-zend-router.spec
index 40d0adc..771d5e9 100644
--- a/php-zendframework-zend-router.spec
+++ b/php-zendframework-zend-router.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-router
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 03763610632a9022aff22a0e8f340852e68392a1
+%global gh_commit f5dbec5398ca98b35170716ec5146029197fe249
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-router
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.0.2
-Release: 5%{?dist}
+Version: 3.1.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,48 +30,75 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-router/pull/39.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.6 with php-autoloader(%{gh_owner}/zend-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:10
+%else
+BuildRequires: php-composer(container-interop/container-interop) < 2
+BuildRequires: php-composer(container-interop/container-interop) >= 1.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.5
+%endif
# From composer, "require-dev": {
-# "zendframework/zend-i18n": "^2.6",
-# "squizlabs/php_codesniffer": "^2.3",
-# "phpunit/phpunit": "^4.5",
-# "sebastian/version": "^1.0.4"
+# "phpunit/phpunit": "^5.7.22 || ^6.4.1",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-i18n": "^2.7.4"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.6 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
+# remirepo:4
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.6
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+%endif
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.4.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "container-interop/container-interop": "^1.1",
-# "zendframework/zend-http": "^2.5",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-stdlib": "^2.7.5 || ^3.0"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+# "container-interop/container-interop": "^1.2",
+# "zendframework/zend-http": "^2.6",
+# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(container-interop/container-interop) >= 1.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-http) >= 2.6 with php-autoloader(%{gh_owner}/zend-http) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:10
+%else
Requires: php-composer(container-interop/container-interop) < 2
-Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.5
+Requires: php-composer(container-interop/container-interop) >= 1.2
Requires: php-autoloader(%{gh_owner}/zend-http) < 3
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
+Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.6
Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.5
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.7
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
+%endif
# From composer, "suggest": {
# "zendframework/zend-i18n": "^2.6, if defining translatable HTTP path segments"
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-autoloader(%{gh_owner}/zend-i18n)
%endif
# From composer, "conflict": {
@@ -110,7 +137,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -146,9 +172,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
fi
done
exit $ret
@@ -166,6 +193,14 @@ exit $ret
%changelog
+* Tue Jun 19 2018 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+- raise dependency on PHP 5.6
+- raise dependency on container-interop/container-interop 1.2
+- raise dependency on zendframework/zend-http 2.6
+- raise dependency on zendframework/zend-servicemanager 2.7.8
+- raise dependency on zendframework/zend-stdlib 2.7.7
+
* Sat Dec 9 2017 Remi Collet <remi@remirepo.net> - 3.0.2-5
- switch from zend-loader to fedora/autoloader