summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 11:12:40 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 11:12:40 +0200
commite3a2d66c7e5c07c3cf07eeaa5669e0ffdacf750f (patch)
treeb363244010db7472767299f6616f1790ad5a8be2
parent059f6ddaa6e9600021d9050501574d918a0b58c8 (diff)
php-zendframework-zend-router: 3.0.2
-rw-r--r--composer.json3
-rw-r--r--php-zendframework-zend-router.spec26
2 files changed, 23 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index f10e02b..d7c9330 100644
--- a/composer.json
+++ b/composer.json
@@ -29,6 +29,9 @@
"suggest": {
"zendframework/zend-i18n": "^2.6, if defining translatable HTTP path segments"
},
+ "conflict": {
+ "zendframework/zend-mvc": "<3.0.0"
+ },
"extra": {
"branch-alias": {
"dev-master": "3.0-dev",
diff --git a/php-zendframework-zend-router.spec b/php-zendframework-zend-router.spec
index 6414a43..52dc371 100644
--- a/php-zendframework-zend-router.spec
+++ b/php-zendframework-zend-router.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5a4666ced887d2a9e920e8aaa604b3cc39648b1a
+%global gh_commit 03763610632a9022aff22a0e8f340852e68392a1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-router
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.0.1
+Version: 3.0.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -133,11 +133,22 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if which php71; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+# remirepo:2
+fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -157,6 +168,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
+- update to 3.0.2
+
* Tue Apr 19 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
- initial package