summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-19 09:47:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-19 09:47:11 +0200
commit259e326fe4feed665f1dc61a72d399679a067606 (patch)
tree27fea74159a6e5f2504d51d9b546341dca99f943
php-zendframework-zend-router: 3.0.1 (new package)
-rw-r--r--Makefile3
-rw-r--r--composer.json58
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-zendframework-zend-router.spec160
4 files changed, 249 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..f10e02b
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,58 @@
+{
+ "name": "zendframework/zend-router",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "mvc",
+ "routing"
+ ],
+ "homepage": "https://github.com/zendframework/zend-router",
+ "autoload": {
+ "psr-4": {
+ "Zend\\Router\\": "src/"
+ }
+ },
+ "require": {
+ "php": "^5.5 || ^7.0",
+ "container-interop/container-interop": "^1.1",
+ "zendframework/zend-http": "^2.5",
+ "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+ "zendframework/zend-stdlib": "^2.7.5 || ^3.0"
+ },
+ "require-dev": {
+ "zendframework/zend-i18n": "^2.6",
+ "squizlabs/php_codesniffer": "^2.3",
+ "phpunit/phpunit": "^4.5",
+ "sebastian/version": "^1.0.4"
+ },
+ "suggest": {
+ "zendframework/zend-i18n": "^2.6, if defining translatable HTTP path segments"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.0-dev",
+ "dev-develop": "3.1-dev"
+ },
+ "zf": {
+ "component": "Zend\\Router",
+ "config-provider": "Zend\\Router\\ConfigProvider"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Router\\": "test/"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "upload-coverage": "coveralls",
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit",
+ "test-coverage": "phpunit --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..e9a1ec5
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-zendframework-zend-router.spec b/php-zendframework-zend-router.spec
new file mode 100644
index 0000000..e8992ce
--- /dev/null
+++ b/php-zendframework-zend-router.spec
@@ -0,0 +1,160 @@
+# remirepo/Fedora spec file for php-zendframework-zend-router
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 5a4666ced887d2a9e920e8aaa604b3cc39648b1a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-router
+%global php_home %{_datadir}/php
+%global library Router
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 3.0.1
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: http://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.5
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.5
+# From composer, "require-dev": {
+# "zendframework/zend-i18n": "^2.6",
+# "squizlabs/php_codesniffer": "^2.3",
+# "phpunit/phpunit": "^4.5",
+# "sebastian/version": "^1.0.4"
+BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
+BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+
+# From composer, "require": {
+# "php": "^5.5 || ^7.0",
+# "container-interop/container-interop": "^1.1",
+# "zendframework/zend-http": "^2.5",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+# "zendframework/zend-stdlib": "^2.7.5 || ^3.0"
+Requires: php(language) >= 5.5
+%if ! %{bootstrap}
+Requires: php-composer(container-interop/container-interop) >= 1.1
+Requires: php-composer(container-interop/container-interop) < 2
+Requires: php-composer(%{gh_owner}/zend-http) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-http) < 3
+Requires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
+Requires: php-composer(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.5
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
+# From composer, "suggest": {
+# "zendframework/zend-i18n": "^2.6, if defining translatable HTTP path segments"
+%if 0%{?fedora} >= 21
+Suggests: php-composer(%{gh_owner}/zend-i18n)
+%endif
+%endif
+# From phpcompatinfo report for version 2.5.1
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+zend-router provides flexible HTTP routing.
+
+Routing currently works against the zend-http request and responses,
+and provides capabilities around:
+
+* Literal path matches
+* Path segment matches (at path boundaries, and optionally validated
+ using regex)
+* Regular expression path matches
+* HTTP request scheme
+* HTTP request method
+* Hostname
+
+Additionally, it supports combinations of different route types in tree
+structures, allowing for fast, b-tree lookups.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
+ 'namespaces' => array(
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+))));
+require_once '%{php_home}/Zend/autoload.php';
+EOF
+
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Tue Apr 19 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
+- initial package
+