summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-11 09:58:40 +0100
committerRemi Collet <remi@remirepo.net>2017-12-11 09:58:40 +0100
commite5a6460bce0771083bd5b982ca8be797708854d2 (patch)
tree470b922f3ec51515445d03a00331115cfd3a4b13
parent8120d4508d4e624eb53663736965397771cfd18e (diff)
clean
-rw-r--r--php-zendframework-zend-progressbar.spec20
1 files changed, 7 insertions, 13 deletions
diff --git a/php-zendframework-zend-progressbar.spec b/php-zendframework-zend-progressbar.spec
index af701e5..758e0b1 100644
--- a/php-zendframework-zend-progressbar.spec
+++ b/php-zendframework-zend-progressbar.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -99,8 +98,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -120,22 +117,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md